0

I'm trying to install all the packages needed to use Ajenti on my raspberry pi 2. Originally I simply ran the wget command Ajenti has for automatic quick install. Everything went over smoothly until it needed to install greenlet==dev.

When it got to that point in the install it reports the following error back to the terminal:

Could not find a version that satisfies the requirement greenlet==dev (from versions: 0.4.2, 0.4.6, 0.3.2, 0.4.9, 0.4.10, 0.2, 0.4.7, 0.4.4, 0.3.3, 0.1, 0.3.4, 0.3, 0.4.0, 0.4.5, 0.4.9, 0.3.1, 0.4.1, 0.4.3, 0.4.10)

Cleaning up...

No distributions matching the version for greenlet==dev Storing debug log for failure in /root/.pip/pip.log

If you investigate the log file it reads:

Could not fetch URL https://pypi.python.org/simple/greenlet--dev/: 404 Client Error: Not Found Will skip URL https://pypi.python.org/simple/greenlet--dev/ when looking for download links for greenlet-dev

Getting page https://pypi.python.org/simple/

URLs to search for versions for greenlet-dev:

Will skip URL https://pypi.python.org/simple/greenlet--dev/ when looking for download links for greenlet-dev

Could not find any downloads that satisfy the requirement greenlet-dev

No distributions at all found for greenlet-dev

Cleaning up...

Exception information: Traceback (most recent call last):

File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in main status = self.run(options, args)

File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 290, in run requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)

File "/usr/lib/python2.7/dist-packages/pip/req.py", line 1178, in prepare_files url = finder.find_requirement(req_to_install, upgrade=self.upgrade)

File "/usr/lib/python2.7/dist-packages/pip/index.py", line 277, in find_requirement raise DistributionNotFound('No distributions at all found for %s' % req)

DistributionNotFound: No distributions at all found for greenlet-dev]

-Pastebin of complete log file.

I've searched google for the error but haven't found anything concrete or relating to this specific issue. I made sure all the other packages were installed correctly. When I attempt to install or upgrade them on their own the report that they are all up to date with the latest version installed.

When you execute the command pip list it shows that everything is installed and list up to date versions as well. Including the base of greenlet version 0.4.10.

Ajenti allows me to log in, but once logged in it redirects to a completely blank page outside of the header/navigation bar. Some people report this issue with ajenti for other reasons which I can pin down later. I'd like to eliminate the possibility of it being related to greenlet-dev not being install or something it depends on not being properly installed.

Does anyone know what is/could be going wrong here and how to correct it? Any help is appreciated.

  • can you run these commands for me please"pip install greenlet" then "easy_install greenlet" then "/etc/init.d/ajenti restart" then "service agent restart" and tell me what the output is for every step? – Mohammad Ali Sep 19 '16 at 22:57
  • For pip install greenlet: Requirement already satisfied (use --upgrade to upgrade): greenlet in /usr/local/lib/python2.7/dist-packages Cleaning up... For easy_install greenlet: error: can't create or remove files in install directory The following error occurred while trying to add or remove files in the installation directory: [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/test-easy-install-28952.write-test' – Jem Sep 20 '16 at 19:47
  • Have you tried upgrading? – Mohammad Ali Sep 20 '16 at 19:47
  • I amended my comment. It gives an error when you run easy_install greenlet. I've tried upgrading greenlet with the install with the --upgrade parameter and it says everything is up to date. Upgrading the entire OS has always been successful without error. – Jem Sep 20 '16 at 19:56
  • Can you please try easy_install but with sudo in front of it so it gets write permission – Mohammad Ali Sep 20 '16 at 21:39
1

Try the following manual install method.

First run wget http://repo.ajenti.org/debian/key -O- | apt-key add - and add repository key

Next, add Add repository to /etc/apt/sources.list by running echo "deb http://repo.ajenti.org/debian main main debian" >> /etc/apt/sources.list

Then perform the install apt-get update apt-get install -y ajenti apt-get install python-pip apt-get install python-dev apt-get install libevent-dev pip install -U gevent pip install greenlet==dev pip install -U psutil /etc/init.d/ajenti restart

service ajenti restart

That should complete the installation and start the panel on HTTPS port 8000. The default username and password are root, and admin, respectively.

Source

///Run all commands as sudo if you are having permission errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.