1

I randomly started having trouble using apt-get on a Raspberry Pi 3 running Raspian. I can remove packages just fine, but when I try to install one, I always get the message

E: Unable to locate package

The command is run while SSHing into the pi (if that should matter for some reason).

I found lots of things online saying to simply run apt-get update, but that doesn't fix it for me. And when I try to install a package that is already up to date, the functionality is as expected. What's going on?

  • What package do you want to install? Which version of Raspbian do you run? – Thomas Weller Sep 16 '16 at 20:56
  • @ThomasWeller this happens for any package I am trying to install. This is Raspian 4.4.13-v7 – Danny Buonocore Sep 16 '16 at 21:09
  • When I started getting issues with apt-get I ended up restarting from scratch (new image on new sd card) – Jaromanda X Sep 17 '16 at 6:33
  • @JaromandaX yeah that's what I ended up doing unfortunately... just hope it doesn't happen again – Danny Buonocore Sep 17 '16 at 16:28
  • It will, because SD cards aren't meant to be used like we use them in Pi's – Jaromanda X Sep 17 '16 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.