0

I have set up my Raspberry Pi 3 Model B to run Parrot Security OS. I wish to run the Parrot Security OS on RPi without connecting it to my monitor and keyboards - headless.

I have tried installing TightVNC and other remote desktop application, but no hope. And, I cannot even SSH to the OS.

I really appreciate if anyone can help or share their experiences on how to connect to Parrot Security OS on RPi either through VNC or SSH.

  • I don't see why this would be any different than on any other GNU/Linux system. Presumably Parrot comes with a firewall configured, which pi oriented distros usually do not -- but that is a very minor issue, you just want to make sure the SSH port is open. – goldilocks Sep 17 '16 at 15:43
  • Would you mind to shed some lights on how to enable the SSH port? Thanks and appreciated – gUAvAS Sep 18 '16 at 1:25
1

Not sure if is good idea to answer old threads... anyway I saw is still not marked as resolved. I recently bought a raspberry pi 3 and tried parrot. I installed vnc4server and did a daemon to easily start|stop|restart it. You can view the code here: vnc daemon.

As you can see in the code, I launch VNC server with root user which I think is not a good practice... anyway, you can change it. Then, I created on /root/.vnc the empty file .Xresources using touch .Xresources. The problem using arm version of Parrot is that the /root/.vnc/xstartup default file is not working with its default config... by default, on arm Parrot the Desktop Environment is Xfce, so you must change this file in order to get working. My xstartup file is this:

#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
startxfce4 &

And don't forget to launch vnc4passwd to set up the password on your VNC server.

After all of this, you can execute update-rc.d vncboot enable in order to set up the daemon to automatically start on reboot.

I hope this helps to somebody. Cheers!

0

From what I understand parrot has left remote connection out of its build so u cant be hacked in it.If its not a 2 way connection it blocks incoming requests for that connection. The only way I think you can do it, is a reverse ssh shell to your pc from the PI. I use Parrot Security on my PI and with headless I use this method:

Here is the command you want to use on the PI

ssh -fN -R 5900:localhost:22 username@yourMachine-ipaddress

So this ssh connection request originating from PI to your machine will make sure that any ssh connection request for port 5900 on your machine is forwarded to port 22 of the PI

Now do an ssh connection request from your machine to your own machine at port 5900:

ssh username@localhost -p 5900

Here, though it may seem like you are doing ssh on localhost but your request would be forwarded to remote host

You also dont have to use port 5900. Any non used port will work. In fact, your better off checking first to see whats avalible. This command will tell you what ports are being used and by what, so pick something not on this list from the below command.

netstat -lnptu

also nmap another tool on parrot you probably are aware of, or have even used can solve which ports are available

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.