0

I was trying to setup my new Raspberry Pi 3 (Model B). I do have a wireless mouse and monitor but no keyboard so I decided to go for a headless-ish setup. Here's what I did:

  1. I installed the latest version of NOOBS on my SD card and inserted into the Pi.
  2. I connected my Pi to the monitor and powered it up.
  3. I clicked through the installation steps to install Raspbian on the Pi. That went smooth and I could see Raspbian setup on the Pi pretty soon.
  4. I powered down the Pi ("shutdown" from Menu) and disconnected it from my monitor. I then connected it to my router with an ethernet cable and powered it up again. (the monitor I use is a TV which is setup in a different room than the router so I can't connect them at the same time without significant effort).
  5. Next I did arp -a to determine Raspberry's IP address which worked fine. (192.168.1.40)
  6. Then I tried to ssh into the address I discovered: ssh pi@192.168.1.40, which failed with a Connection Timed Out error.
  7. Trying to ping the IP gives me:

Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
ping: sendto: No route to host
Request timeout for icmp_seq 4
ping: sendto: Host is down

Is there any way for me to fix this problem without having to go buy a keyboard? I searched around a lot and all solutions involve poking the network from the Pi command line.

I'm attempting to ping my Pi from my Macbook. I've disabled Firewall on my Macbook.

Thanks for the help.

  • Try to get ip address from router web interface. – kev Sep 19 '16 at 13:40
  • what is the IP address on your Mac? – stevieb Sep 19 '16 at 13:43
  • I've cross checked the IP address using the router webpage and it's the same. – Chocolava Sep 19 '16 at 14:40
  • @stevieb, do you mean the IP address of my Mac? It's 192.168.1.34. – Chocolava Sep 19 '16 at 14:41
  • All those steps you've listed don't mention enabling ssh from raspi-config. By default it is disabled – dbmitch Nov 19 '16 at 18:28
1

I don't think using arp this way is definitive. You are just looking at a cache on the Mac. A better tool in this context would be nmap.

If that address doesn't respond to pings and you haven't done something unusual to the pi, it is not the pi's address and probably doesn't really belong to anything, hence you get a time out. If it were the pi and ssh simply weren't running, you would get an immediate "Connection refused".

Put another way, your assertion that the pi is not responding to pings is based on a leap of faith that it is connected to the network and you have the correct address for it. At least one of those assumptions is false.

You should try the keyboard and monitor with the pi connected to the router so you can check directly whether it is getting an address properly. If you configured it to use a static address it will not work unless you also assign that on the router.

You should log into your router and see what devices it says are currently part of the network and what addresses they have.

  • I've cross checked the IP address using the router webpage and it's the same. I didn't configure it to have a static address. The router does tell me that the pi is connected but the IP address gives me request timeout. Not sure what's going wrong here. – Chocolava Sep 19 '16 at 14:43
  • I don't see what you can do beyond checking what is going on from the pi side. It's obviously not online at that address; the only other way for a time out to occur is if the pi had a firewall configured to drop packets, which it does not by default and would be very unlikely to happen by accident because while they can drop packets, firewalls generally don't; they deny connections immediately. Likewise, trying to connect to a service not running doesn't produce a time out. If the service is running but non-responsive this could happen, although that still doesn't explain the ping issue. – goldilocks Sep 19 '16 at 14:47
  • Put another way: A time out can only indicate one of three things: 1) No system at that address; 2) The system's firewall is actively dropping packets instead of denying connections; 3) A non-responsive service on a port. However, #3 doesn't apply to pings, so that leaves you with possibilities 1 and 2. Note that a system that is unable to respond because of internal problems would count as 1, but there is an infinite range of possible reasons for that and you'd have to check the system itself to find out. – goldilocks Sep 19 '16 at 14:50
  • Thank you for that information! It seems pretty clear then that I'd have to get myself a keyboard to test the Pi out and connecting it to wifi directly maybe will work instead of the ethernet cable. It still blows me that the Pi could have internal problems because it seems to work flawlessly when connected to the monitor and mouse. :( – Chocolava Sep 19 '16 at 14:56
  • 1
    I've gotten a lot of use out of the Fing Android client for things like this. It gives a nice quick sanity check for basic network issues, and provides a list of available services from each available IP. – goobering Sep 19 '16 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.