1

I'm using a Raspberry Pi 2 Model B running Raspian Jesse Lite with the official camera board. When I try and take a timelapse, it runs for about two minutes, then stops.

I'm running raspistill --timelapse 60000 --quality 100 --width 1440 --height 900 --output ./images/image.jpg --exposure auto. The first two images take fine, but as soon as the second image is taken, the app exits.

The documentation tells me there's a timeout, and that it defaults to 5 seconds, but even if I set the timeout to 999999999, it still stops after two minutes.

pi@raspberrypi:~/ $ /opt/vc/bin/raspistill --timelapse 60000 --quality 100 --width 1440 --height 900 --output ./images/image.jpg --exposure auto

pi@raspberrypi:~/ $

EDIT: Here's what happens when I run it with -v:

raspistill Camera App v1.3.8

Width 1440, Height 900, quality 100, filename ./images/image.jpg

Time delay 5000, Raw no

Thumbnail enabled Yes, width 64, height 48, quality 35

Link to latest frame enabled no

Full resolution preview No

Capture method : Capture on timelapse

Preview Yes, Full screen Yes

Preview window 0,0,1024,768

Opacity 255

Sharpness 0, Contrast 0, Brightness 50

Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0

Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'

Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128

Rotation 0, hflip No, vflip No

ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000

Camera component done

Encoder component done

Starting component connection stage

Connecting camera preview port to video render.

Connecting camera stills port to encoder input port

Opening output file ./images/image.jpg

Enabling encoder output port

Starting capture 1

Finished capture 1

Opening output file ./images/image.jpg

Enabling encoder output port

Starting capture 2

Finished capture 2

Closing down

Close down completed, all components disconnected, disabled and destroyed

EDIT 2: Someone in another question suggested sudo rpi-update`. Tried that (needed to install it, as it's not part of the lite version of Raspbian) and still had no luck.

Am I doing something wrong here?

  • You need a place holder for the variable file name number. As in "The specific value is the time between shots in milliseconds. Note that you should specify %04d at the point in the filename where you want a frame count number to appear". The second image needs to be written to a different file name. – zedman9991 Sep 21 '16 at 16:38
3

Not an answer, just observed behaviour:

Odd... - I just tried your command on my Pi Camera and got the exact same result - 2 images taken then shutdown.

For testing I reduced your timelapse value to 6000 and the same thing happened - 2 images taken then shutdown.

I then added the timeout parameter (set to 30000) and it worked as expected - it took 6 images and then shutdown.

I then set the timeout parameter to 999999999 and it seems to be working (I don't plan to wait till 999999999mS pass to fully test... but it has gone past 2 minutes).

So... I'd set the timeout value. Here was the command I ended up using:

raspistill --timelapse 6000 --quality 100 --width 1440 --height 900 --output .
/images/image%04d.jpg --exposure auto -v -t 999999999
  • 1
    I think the different filename is the key here. As @zedman9991 pointed out in a comment on my question, it might quit when the filename already exists, which would explain the "try to write and then quit" behavior. Because I'm uploading these files to a remote system, I can simply delete the files when they've been uploaded. – DrFrankly Sep 21 '16 at 17:12
  • @DrFrankly @zedman9991 it is not related to the filename - just tested that and I get the same behaviour with ./images/image.jpg as I get with ./images/image%04d.jpg in the command line – KennetRunner Sep 21 '16 at 19:49
  • You're right, it did still happen. Adding the timeout worked. It's odd that it needs one, but oh well, it works now. Thanks! – DrFrankly Sep 22 '16 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.