2

I have an Edimax USB WiFi adapter on my Raspberry Pi 2B, in Germany. The adapter works and is able to list nearby networks (iwlist wlan0 scan).

It shows all my neighbors' networks, except mine. The WiFi strength is excellent (I'm using on my phone), the SSID is not hidden (I can see it from my phone) and it's on channel 12. wpa_gui shows the same scan list. Security is WPA2 PSK CCMP. Restarting the router didn't work.

If I just blindly set the wpa supplicant it won't connect either.

Any idea what could be causing this?

  • 1
    That you can see the SSID on your phone, that is connected, does not mean it's not hidden. Are you using 2.4 GHz or 5 GHz on your router? Does the WiFi adapter support the same frequency? – Bex Sep 22 '16 at 7:39
  • When I first connected to the access point with my phone the SSID was visible. The network is in 2.4GHz (verified by WiFi Analyzer app) and the adapter supports this frequency. – BoppreH Sep 22 '16 at 12:23
  • Possible duplicate of How to enable Wi-Fi channel 12 on Raspberry Pi 3? – Dmitry Grigoryev Sep 22 '16 at 16:54
  • Change the channel on your router to 3,6 or 9. Depending on how which channel your neighbours have. It sucks becuase the router most probably select 12 because it has least traffic on there. Get 5ghz AP? – Piotr Kula Sep 22 '16 at 18:02
  • @Dmitry, my raspberry is model 2 and rpi-update didn't fix the problem. Maybe because the adapter is external. ppumkin, that looks like it would work but I'm saving as last resort and getting admin on the router may not possible. – BoppreH Sep 22 '16 at 18:35
3

Run sudo iwlist wlan0 channel and post the result.

I do not know what the channels are in Germany, but channel 12 is not supported in some jurisdictions.

  • Yes, it's missing channel 12. That narrows down the problem. – BoppreH Sep 22 '16 at 18:26
  • The adapter was purchased in a country with restricted channels. I could not find a way to force the hardware to see the other channels. Using a different one fixed the problem. – BoppreH Sep 22 '16 at 19:45
1

Try running raspi-config and set Wifi Country to Germany. Channel 12 is disabled in the US which is probably the setting you use.

  • Was already Germany, and changing to another code that I'm sure supports channel 12 didn't fix the problem either. – BoppreH Sep 22 '16 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.