3

I've a Rpi 3 Model B V1.2 with an Intenso 16GB Micro SD HC (up to 90 MB/s) running a RASPBIAN JESSIE LITE (Rel. Date: 2016-05-27), power is supplied via USB by a Linux machine.

The system worked correctly for about a week, but since yesterday the webserver and ssh were not working anymore, although the previously installed VPN was/is still connecting to the VPN Server.

Apparently the power of RPI was taken off without it first shutting down correctly (not 100% sure about this).

Today I connected a monitor and find out that the boot is stucked on EXT4-fs error (see attached image), I tried to login but this is not possible, everytime I type something a new line with error appears.

RPI stuck on boot because of EXT4-fs error

How can I fix this error? If no fix possible, how can I recover certain files? (I've no backup of a small app I did)

2

Take out the microSD card from your RPi, plug it into the card reader and try to backup your files on the laptop.

Then you can either attempt to fix the filesystem of the card with fsck (again, on the laptop). If you're unable to fix it to a bootable state, you'll have to reflash the microSD card with the image and start from scratch.

  • fsck of part named "linux" said everything was fine.. so nothing was actually corrected. Saving of files worked partially. – Ñhosko Sep 22 '16 at 14:53
  • Looking at your log it seems that some important files got corrupted, so you'll probably have to reflash a new image on it. Also check this thread. – Dmitry Grigoryev Sep 22 '16 at 15:06
  • Correction.. saving of files was successful. – Ñhosko Sep 22 '16 at 15:06
  • do you think this could have been caused because of removing power without turning off rpi? – Ñhosko Sep 22 '16 at 15:08
  • 1
    For the record (in case any brand-new rpi user faces the same problem as i did..): connect SD to Linux, do "df" to find the name, then do "fdisk -l /dev/sdX" to see partitions of the SD.. search for the one named "linux" (in mc case was sdX2), finally I did "fsck -l /dev/sdX2" to scan and fix that partition. For me it did not helped, but for others it may... – Ñhosko Sep 22 '16 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.