0

Im currently trying to install hadoop 2.7.2 on my new raspberry pi 3, but I'm running into issues getting protobuf setup.

I'm currently getting the tar.gz from https://github.com/google/protobuf/archive/v2.5.0.tar.gz

and then running the following.

$ tar xvf v2.5.0.tar.gz
$ cd protobuf-2.5.0
$ ./autogen.sh

When I get here though, I run into this issue

Google Test not present.  Fetching gtest-1.5.0 from the web...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1586  100  1586    0     0  15603      0 --:--:-- --:--:-- --:--:-- 15702
bzip2: (stdin) is not a bzip2 file.
tar: Child returned status 2
tar: Error is not recoverable: exiting now

What am i missing here? Has anybody who has successfully setup protobuf and hadoop on a rpi3 encountered something similar to this?

2
  • Looks like you have a bad download, have you tried to download it again? Sep 23 '16 at 21:46
  • I've tried redownloading and it multiple times to no avail.
    – cptHoek
    Sep 23 '16 at 22:36
1

I don't know why you are using protobuf 2.5.0, but I suspect it's because hadoop requires that version and won't work with 3.0.0.

I'd suggest just getting stuff from github, like this. In general, piping the output of curl to a shell is a bad habit to have (from a security point of view). It's OK in this particular case, of course, but I took this opportunity to point out a bad habit that may bite you in the future.

git clone https://github.com/google/googletest
cd googletest
git checkout release-1.5.0
cd ..
git clone https://github.com/google/protobuf
cd protobuf
git checkout v2.5.0
ln -s ../googletest gtest
./autogen.sh
./configure
make -j 4
sudo make install
sudo ldconfig

If you also want to build the python bindings:

cd python
python setup.py build
sudo python setup.py install
python3 setup.py build
sudo python3 setup.py install
0

The autogen.sh checks if gtest directory exists and if absent, try to get http://googletest.googlecode.com/files/gtest-1.5.0.tar.bz2. However the URL does not exist so that results in 404 error.

Thus try this in protobuf-2.5.0 directory, before executing autogen.sh, like this. curl -kL https://github.com/google/googletest/archive/release-1.5.0.tar.gz | tar zxvf - mv googletest-release-1.5.0 gtest ./autogen.sh

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.