1

So I installed Snappy Ubuntu Core just like the offical guide. Found its IP. Everything works. I Followed step two of the guide which is updating package.

sudo apt-get update && sudo apt-get dist-upgrade

After the update it says to reboot. So I do that and then It won't connect to the ethernet.

So I connect a monitor and keyboard login in and type ifconfig on terminal it returns the lo adapter and so has no ip address.

/etc/network/interfaces is pretty much empty, which is where I usually put a static IP in raspbian.

How do I fix this and/or where do I look for debug information?

Edit. So after reflashing I note the packages which are dist-upgrade will update:

accountsservice apparmor apport apt apt-transport-https apt-utils base-files bash bash-completion bind9-host bsdutils cloud-init command-not-found command-not-found-data console-setup console-setup-linux curl dh-python distro-info-data dmidecode dnsmasq-base dnsutils dosfstools dpkg fuse gcc-5-base gnupg gpgv grep grub-legacy-ec2 ifupdown init init-system-helpers initramfs-tools initramfs-tools-bin initramfs-tools-core isc-dhcp-client isc-dhcp-common keyboard-configuration klibc-utils language-selector-common less libaccountsservice0 libapparmor-perl libapparmor1 libapt-inst2.0 libapt-pkg5.0 libbind9-140 libblkid1 libcurl3-gnutls libdns-export162 libdns162 libdrm2 libexpat1 libfdisk1 libfuse2 libgcrypt20 libglib2.0-0 libglib2.0-data libgnutls-openssl27 libgnutls30 libidn11 libisc-export160 libisc160 libisccc140 libisccfg140 libklibc libldap-2.4-2 liblwres141 liblxc1 libmount1 libp11-kit0 libpam-systemd libplymouth4 libpython3.5-minimal libpython3.5-stdlib libsmartcols1 libssl1.0.0 libstdc++6 libsystemd0 libtasn1-6 libudev1 libuuid1 libxml2 linux-firmware linux-headers-raspi2 linux-image-raspi2 linux-raspi2 lsb-base lsb-release lshw lxc-common lxcfs lxd lxd-client mdadm mount mtr-tiny openssh-client openssh-server openssh-sftp-server openssl plymouth plymouth-theme-ubuntu-text pollinate python3-apport python3-commandnotfound python3-distupgrade python3-problem-report python3-software-properties python3-urllib3 python3.5 python3.5-minimal shared-mime-info snapd software-properties-common sudo systemd systemd-sysv tzdata ubuntu-core-launcher ubuntu-release-upgrader-core udev update-notifier-common util-linux uuid-runtime vim vim-common vim-runtime vim-tiny wget

Edit2:

I tried reflashing and did a normal apt-get upgrade instead of a dist upgrade. Same problem.

  • Note that snappy ubuntu core doesn't use apt, so I'm not sure what you're running. – Kyle Sep 26 '16 at 13:15
  • @Kyle I'm not sure what you mean. I literately did the steps the guide suggest. so apt-get did work. – janw Sep 26 '16 at 14:52
  • 1
    Reflash the snappy image back and take a note of packages which apt-get dist-upgrade is trying to upgrade. – Dmitry Grigoryev Sep 26 '16 at 15:13
  • I think something corrupt it, creating new config on /etc/network/interfaces might help. – xdhe Sep 26 '16 at 16:57
  • @DmitryGrigoryev I've added a list of packages which it will update. – janw Sep 26 '16 at 18:01
0

I believe this is related to "Predictable Network Interface Names". This is a possible workaround: http://pete.akeo.ie/2016/05/help-i-lost-all-networking-on-my.html

However, I have decided to accept it instead of disabling it. Here is what I have done:

First, run networkctl to get the actual name of the interface:

root@pi ~ # networkctl
IDX LINK             TYPE               OPERATIONAL SETUP
1 lo               loopback           carrier     unmanaged
2 enxa1b2c3d4e5f6  ether              off         unmanaged

2 links listed.

Replace my entry in /etc/network/interfaces/90-eth0.cfg with:

auto enxa1b2c3d4e5f6
#iface enxa1b2c3d4e5f6 inet dhcp
iface enxa1b2c3d4e5f6 inet static
    address 192.168.1.10
    netmask 255.255.255.0
    gateway 192.168.1.1
    dns-nameservers 192.168.1.1

So now my interface is not called eth0 anymore, but it works. And I don't fight against systemd's new approach, which I think makes quite a lot of sense.

  • I abandoned ubuntu snappy, I just went with rasbian. I'll accept it nonetheless. It sounds right.. – janw Oct 6 '16 at 9:06
0

Urkom gave the right cue and the link he provides gives the full answer from Cerin (I am just copy/pasting):

I ran into this on a fresh install of server 16.04 on a Raspberry Pi. For some reason, Network Manager wasn't installed by default, and after running dist-upgrade and then rebooting, I had no network.

I followed the steps at this blog to get it working again. Essentially, the mapping for eth0 had become corrupted. Normally, Network Manager can automatically fix this, but without it, you have to do it yourself. To do that, I first ran:

sudo networkctl

which showed me all my network interfaces like lo, wlan0 and something called enc238897s9879c3, which is actually supposed to be eth0.

To correct the mapping, I ran:

sudo ip link set enc238897s9879c3 name eth0
sudo systemctl restart networking

and that fixed it. Running ifconfig showed I had an IP, and running ping google.com showed I had Internet.

It worked perfectly for me.

Also, the Snappy Core does use apt for upgrading as indicated in the guidelines here: https://developer.ubuntu.com/en/snappy/start/raspberry-pi-2/

-1

Please find the latest beta images for RPi2/3 here. Follow the same instructions and you should be good to go.

  • I tried that but it won't connect to the internet to begin with. So I can't login. – janw Sep 27 '16 at 16:33
  • Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be highly preferable to include the essential parts of the answer here, and provide the link for reference.We're trying a new policy with regard to informationless link-only answers here. If this post is not edited to contain information that can stand as an answer, however minimal, in 48 hours it will be converted to Community Wiki to simplify having it corrected by the community. – Ghanima Sep 27 '16 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.