I have a perfectly running Raspberry Pi 3 Model B, with a Raspbian Distribution on a 16 GB SD-Card. I connected a Screen with a HDMI-to-DVI Connector to it, a Mouse and Keyboard and I also have SSH access. Further I got a Kuman 3.5 Inch Touch-Display, which I want to use on it. I read myself through the Internet enough that I know I can't use the Screen and the HDMI-Screen simultaneously. So I connected the Screen to the right Pins, the Backlight already works. So I take the Drivers that are sent with it. Searched the one for my Distribution, extracted the Script onto my Raspberry Pi and launched it through./LCD-35 in the terminal. After a few seconds it Reboots and the Color-Test appears. The Screen for the NOOBS-Recovery-Mode appears, which I can still use, then a few seconds later:

---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2)

I can unplug it, like I said, the color-test and the recovery and the same again, regardless of having the HDMI-Cable, the Display, USB-Mouse/Keyboard plugged in or not. Before I made a .img of my card so I can flash it again to have my old state, nonetheless, the LCD won't get to work through that.

Can you help me configuring the LCD? I already tried it 2 times this way, both times the same.

UPDATE: I installed a IMG of Raspbian sent with the Display, which worked, let's say 50 %. It worked as a mini-screen, but not more. The touch wouldn't work. I tried to calibrate it, read and did the instructions for my screen, but nothing helped. It's not the original problem but I'd still rather install it on a working system without the special Raspbian.

  • Have you validated your connection between the display and the Pi Commented Sep 26, 2016 at 14:09
  • How would i validate it? Do you mean physically or on software-level? Commented Sep 27, 2016 at 9:17
  • Have you tried using different SD cards? Commented Sep 27, 2016 at 16:53
  • Im making a second SD-Card right now to try it, but what did you mean by validating it? Commented Sep 28, 2016 at 11:25
  • I ment to say to see if you have connect f it correctly but since you are getting some output from the Pi it's likely not a wiring problem Commented Sep 28, 2016 at 11:59

9 Answers 9


Here are the drivers and the description of how to install the screen given by Kumantech. I got it working, and touch screen functionality also worked. I actually did this with combination with other tutorial. Issues I had was that the Pi froze on next reboot, but I'm not sure if error was mine, or just weird faith. I'll be playing around with this now and I'll post my further results.

  • 1
    As this question was the first hit for a Google of "kuman driver download pi 3.5"", I thought I'd update the link if anyone has trouble. This is to update @HelpNeeder's answer after trying their first "Here are the drivers and the description" link as it kept sending me to a "Not found due to [reasons]". I think that the link should point to here.
    – user77180
    Commented Dec 5, 2017 at 14:52
  1. Download the driver from here.

  2. Add to /boot/config.txt file the following lines:

    hdmi_cvt 800 480 60 6 0 0 0
  3. Uncompress, move inside theLCD-show folder and Install it (everything with just one command):

    tar xzvf /boot/LCD-show-YYMMDD.tar.gz; cd LCD-show/; ./LCD35-show

Touch function will work after restart.

  • Thanks for sharing, this is the recommended way by Kuman too.
    – jarodsmk
    Commented Dec 19, 2016 at 9:23
  • @jet It requires to have Xserver..? Can I just use framebuffer..?
    – holms
    Commented Apr 11, 2018 at 0:33

I had the same problem and here is how I solved it, this is the error message:

[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2). 

What I found was that the root file setting in the cmdline.txt entry that the driver tries to install was incompatible with the setting in the original /boot/cmdline.txt.

e.g. The original cmdline.txt has root=/dev/mmcblk0p7 where the driver tries to overwrite it has root=/dev/mmcblk0p2.

After changing mmcblk0p2 to mmcblk0p7, the system boots up and the LCD screen works.

  • I used the waveshare drivers and this was the exact fix to the problem for me. Commented Feb 21, 2017 at 4:34

You likely have noobs installed. The premade package by Pi.org. You need Raspbian Jessie-PIXEL. Unfortunately some root files are set up differently in the Noobs installation. To avoid future inconveniences I suggest using Raspbian jessie pixel over noobs. I did this, and it stopped so many errors from occurring. Noobs also prevents the installation of other software and firmware. I always thought Noobs and Raspbian were the same... Guess not.


Hello i had the same problem, i find meanwhile a image that works http://projektsmartmirror.jimdo.com/lcd-display-am-raspberry/

But as soon you upgrade Raspian to the actual version then agein the same error as you get.

I hope this helps to use the diaplay

  • Thanks, ill try it right now, and if you're german (bcus of the website), danke :D Commented Sep 30, 2016 at 12:33
  • The image works as far as i can use the LCD as a Screen, but thats what i had already before. How did you get the touch to work? Mine just isn't working. Commented Sep 30, 2016 at 13:07
  • Your link doesn't work
    – holms
    Commented Apr 11, 2018 at 0:38

I had a world of problems with my Kuman provided touchscreen and OS. I emailed them many times and in the end they sent me a new screen (I didn't even get a white screen on powering on) and their .img on a disc. After that I downloaded the latest waveshare driver following the instructions here and all worked - I still have an issue with text not wrapping on the boot screen but I can live with that. Maybe try a fresh Raspbian img and get the latest driver.


I've also purchased a kuman 3.5 LCD and ran into similar issues. The screen comes with a micro sd card with Raspian already installed with the drivers installed. That was fantastic until 5 minutes later I did

sudo apt-get update

followed by

sudo apt-get upgrade

after the system reboot I would give me the same kernel panic. I contacted the seller and they told me to reinstall the os from the link provided. I did and got it to work but no touch functions. In terminal enter

sudo apt-mark hold raspberrypi-kernel 

and that should stop the error when upgrading. You also have to install the correct driver. It's best to do this using ssh.


I had a similar as one of the answers above - including my first ever Kernel panic !

The error message was:

[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2).

After looking up in the boot partition of my SD card, I saw indeed the cmdline.txt had been modified from the original line:


The LCD driver overwrote it has


I changed the cmdline.txt in /boot/LCD-show/ that used "mmcblk0p2" instead of "mmcblk0p7" to avoid the problem.

I'm still looking for a solution to use both the HDMI and the LCD at the same time.


i had the same issue with a kuman 3.5 inch LCD touchscreen:

  • boot error
  • LCD whitescreen i have the last version of NOOBS (03/12/2017) and the kuman software.

I had the same problem with the error [ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(179,2).

What I found was that the root file setting in the "cmdline.txt" entry that the driver tries to install was incompatible with the setting in the original "/boot/cmdline.txt". E.g. The original cmdline.txt has "root=/dev/mmcblk0p7" where the driver tries to overwrite it has "root=/dev/mmcblk0p2". After changing "mmcblk0p2" to "mmcblk0p7", the system boots up and the LCD screen works.

This actually works but in the kuman software, cmdline.txt file is in /usr repository, do the modification and the basic installation will work.


Not the answer you're looking for? Browse other questions tagged or ask your own question.