0

I just got a Raspberry Pi 3 and am having trouble booting it up.

I bought a microSD card, and followed this guide to install Ubuntu for it https://developer.ubuntu.com/en/snappy/start/raspberry-pi-2/

However, when plugging the microSD card into the Pi and plug in the power cord (I used this power kit https://www.amazon.com/gp/product/B00MARDJZ4/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1), it's stuck at the screen with the 4 color patches (I left it on for hours). The red light is on, and the other light is orange (yellow?).

I then tried to erase the microSD card with Disk Utility on my Mac to the MS-DOS (FAT) format, and then plugged it into the Pi again to boot up. Nothing happens, the HDMI does not have any output, and only the red light is lit.

I am completely new to this so apologies if this is a noob/ basic question. Any help is appreciated.

EDIT: Thanks to @SteveRobillard suggestion, I am able to get Raspbian working. Still no idea why Ubuntu Snappy instruction is not?

  • 1
    The Pi needs an OS written to the SD card to boot - so " erase[ing] the microSD card with Disk Utility on my Mac to the MS-DOS (FAT) format, and then plugged it into the Pi " will not work. I suggest you download Raspbian burn it to your card and try that to debug the problem. This page has links for the download and installation guide raspberrypi.org/downloads/raspbian – Steve Robillard Sep 27 '16 at 2:44
  • @SteveRobillard your suggestion works, Raspbian is running. Any guess as to why the Ubuntu instruction does not work? – Tri Nguyen Sep 27 '16 at 3:28
  • No idea, I have not tried running snappy only Ubuntu mate. Since snappy is not a full Ubuntu OS but some highbred designed for IOT IIRC. See @Millways answer below. – Steve Robillard Sep 27 '16 at 3:48
  • What size is your SD card? Have you tried using an 8 or 16 GB one? Have you tried using a different card? – bye Sep 27 '16 at 12:01
  • @Alex it is 64GB. It's thee only one I've got. – Tri Nguyen Sep 27 '16 at 13:48
1

Please find the latest beta images for RPi2/3 here. Follow the same instructions and you should be good to go.

  • 1
    Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be highly preferable to include the essential parts of the answer here, and provide the link for reference.We're trying a new policy with regard to informationless link-only answers here. If this post is not edited to contain information that can stand as an answer, however minimal, in 48 hours it will be converted to Community Wiki to simplify having it corrected by the community. – Ghanima Sep 27 '16 at 21:56
  • And another thing to consider. This post has been flagged as an exact duplicate to one of your other answers. If one answer addresses two questions one question should be closed as a dupe of the other. Unless of course details differ in which case the answers should try to go into those details. – Ghanima Sep 27 '16 at 21:58
1

A Raspberry Pi image designed for Pi2 will not work with the Pi3, so you need to install a Pi3 image.

If you are a beginner Snappy is probably not for you. It is not a conventional OS, any you will not have a normal Ubuntu system.

You would be better to start with the official Raspbian image from https://www.raspberrypi.org/downloads/

You could use Ubuntu MATE, but this assumes some experience with Linux.

  • Thanks. I did try with the Raspbian image and it is working. Do you have any idea why the Snappy instruction does not work? It does say "Get started with a Raspberry Pi 2 (or 3)". – Tri Nguyen Sep 27 '16 at 3:29
  • @TriNguyen You would have to ask the developer. The image is based on 15.04 and is quite old. Ubuntu MATE 16.04 (and 15.10) do support PI3, but required some fiddling with the firmware. It is probably possible to replace the Snappy firmware. – Milliways Sep 27 '16 at 3:39
  • The image I have is actually 16.04.1, not 15.04. See cdimage.ubuntu.com/ubuntu/releases/16.04/release – Tri Nguyen Sep 27 '16 at 3:42
1

The reason why Ubuntu Core won't install on the Raspberry Pi 3 is because the Pi 3 is 64bit and the kernel that comes with Ubuntu Core doesn't support ARM64 yet. You can read about it here - https://wiki.ubuntu.com/ARM/RaspberryPi

The work around is to use a custom-build Ubuntu Core image that is a 32bit version so that it can run on the Pi 3. You can find a link to that image in the link above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.