I'm using a Raspberry Pi 3B with a LCD-touchscreen in a project that needs an internet connection. I use the latest Raspbian release and have installed all updates. My goal was to use WiFi but as the client can't provide this I'm going for 3G. I had a Huawei E3531 lying around so it should be convenient to use that one.

I am getting it to work with usb_modeswitch, but the problem is that whenever I insert the dongle, the system starts to freeze at around 10 seconds at the time at regular intervals, like every 50 seconds or so. By freeze I mean the Pi doesn't respond to keyboard, mouse or serial input. But the cursor still blinks, and in X I can see that CPU-load is updating.

First I thought that it was because I've put the command for modeswitching in crontab to run every minute, but I've disabled that and the problem persists.

So, any ideas?

  • 1
    How are you powering the Pi? How are you connecting and powering the 3g dongle? Sep 28, 2016 at 6:48
  • 1
    I'm using a 5V 5A power supply that is connected directly to the GPIO pins, 5V and GND. Sep 28, 2016 at 9:20
  • BTW, by freeze I mean that the Pi doesn't respond on keyboard press, mouse move, serial input and so on, but the cursors are still blinking. Edited the original post. Sep 28, 2016 at 9:21
  • Sorry, missed out that you asked two questions. The dongle is connected by USB, and powered by the USB-port. Sep 28, 2016 at 9:26
  • 1
    I will try a powered hub and get back to you. If it works I will solder connections directly from the powersupply to the USB-port and just bypass the current limiter of the onboard USB-hub. Sep 28, 2016 at 9:55

2 Answers 2


Might be a power problem. According to the specification, E3531 consumes 500mA of current. Furthermore, "Maximum power consumption" is listed to be below 3W, which means you should expect peaks of up to 600mA, or even more the voltage on USB ports is below 5V. Since your RPi 3 provides 1.2A to its 4 USB ports, and assuming E3531 might use 600mA, you have another 600mA left for all other devices. You mention keyboard and mouse, which usually stay under 100mA, so if nothing else is connected you should be fine. If you have something else, or your keyboard and mouse are fancy (wireless, backlight etc.) you should check if you stay under the 1.2A limit. Alternatively, just plug the modem into a powered hub if you have one.

Since you mentioned soldering 5V line to USB ports of RPi, I invite you to be careful and check board schematics. RPi uses this chip to provide current to USB ports, and it will most probably dislike it if you connect its output to 5V. Simple bypasses like this one worked on old RPi boards which had polyfuses.

Anyway, the problem you're having may not be power related at all. Check the output of dmesg for anything suspicious, especially for something repeated every 50 seconds.

  • My plan was to totally cut off the power supplied by the Pi. I need to add a custom USB-port anyway, so I planned to supply that port directly from the power supply. I will first try with a powered hub. Sep 28, 2016 at 11:12
  • I've tried with a powered USB-hub now but the problem remains. I do however notice some strange messages in the dmesg log: USB port disabled by hub (emi ) re-enabling. And then all the USB units disconnects. That could explain why the pi keeps running but input is disabled for awhile. But I guess we can rule out power issues. Sep 28, 2016 at 21:17
  • @JohanLärfars Yep, power issues are certainly out. Please edit your question to include those USB-related messages if you want further help with those. Sep 29, 2016 at 6:43

I have solved this issue by changing the cable between the USB port and the USB dongle.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.