2

I couldn't log in to my Raspberry Pi 3 from ssh so I tried plugging in a monitor, keyboard, and mouse. I got this error message immediately:

end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1, 0)

This came up before it checked if the shift key was held down. I already tried that. The ACT led blinks once and then goes out. The micro SD card was abused some in the past, but I have tried right after copying NOOBs lite.

I tried with a brand new Raspberry Pi 3 and it didn't work. I'm starting to suspect my micro SD card to USB adapter is broken. I have the dromida one from a quadcopter. If anyone has any info on the adapter or a way to fix it, please answer

1

Yep. Start over from the beginning and as long as the hardware is working well it will fix the problem.

Then, as you grow, consider the amount of customization you put into your Rpi setup. Sure you can always start over, but there is a better solution.

Use Win32DiskImager to make .img files of your SD card. I suggest that after you have made enough changes that you don't want to have to do them again, then that's time to make a new image file. I name mine by date, like 2016-09-15.img

So no matter what happens to my system I can always restore it to a known, good, state.

1

Ok i'm not sure what was wrong, but I used a different computer with an SD card slot and used the micro SD to SD adapter that came with the card. That I just copied NOOBs onto the SD card and ta-da it worked!

  • Good start, but that will always keep you at the NOOB stage unless you use Win32DiskImager and save full backups along the way. – SDsolar Oct 1 '16 at 4:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.