4

I am getting EXT4-FS error on Raspberry Pi 3 randomly. I am attaching a screenshot from the display here:. enter image description here

After every restart it works normally for a few hours and then crashes. I am running latest version of Raspbian on it. Pi is powered through power adapter. Any ideas why this happening? Is the SD card corrupt? I am not able to find this log in syslog.


Image Transcript

EXT4-fs error (device mmcblk0p7): __ext4_get_inode_loc:4043: inode #3736018: block 14684221: comm sshd: unable to read itable block
EXT4-fs error (device mmcblk0p7): ext4_wait_block_bitmap:500: comm kworker/u8:0: Cannot read block bitmap - block_group = 453, block_bitmap = 14680069
EXT4-fs (device mmcblk0p7): Delayed block allocation failed for inode 265846 at logical offset 97 with max blocks 1 with error 5
EXT4-fs error (device mmcblk0p7): ext4_journal_check_start:56: Detected aborted journal
EXT4-fs (device mmcblk0p7): Mounting filesystem read-only
EXT4-fs (device mmcblk0p7): This should not happen!! Data will be lost
EXT4-fs error (device mmcblk0p7) in ext4_writepages:2592: IO failure
EXT4-fs error (device mmcblk0p7): ext4_find_entry:1451: inode #131891: comm bash: reading directory lblock 0
(last message repeats several times)
2

The filesystem appears to be getting corrupted repeatedly, and from the sounds of things, that includes while the system is running and not just between boots, which is when it is most likely to occur if you pull the plug at the wrong time.

That should not happen. I would suspect a faulty or worn out SD card at that point. You may also want to check the physical reader on the Pi, if it is a model that uses a full size card the plastic holder can be easily broken without being noticed. The holders on all models can also become lose. However, the holder is most likely not the problem as I think that would cause a very drastic and mysterious failure (as opposed to just filesystem errors) and probably would not corrupt the card (but I could be wrong about that).

  • Thanks for the feedback. It is a microSD card. Can it be fixed fsck etc or this error means it is beyond repair?. I tried "sudo touch /forcefsck" and everything seemed okay on reboot. – Shimano Sep 29 '16 at 11:09
  • 3
    If it is okay and stays okay after fscking at boot then it was just a one time thing, but in the question you say "it works normally for a few hours and then crashes". If that happens afterward, without having pulled the plug, it shouldn't; the filesystem does not just spontaneously become corrupted for no reason, and unless you are doing something really weird the cause here is either software bug (which is unlikely in this case or a very high percentage of users would have this problem) or, most likely, hardware failure (i.e., defective card). – goldilocks Sep 29 '16 at 11:14
  • hi thanks for the comment. It happened again after running fsck several times on boot. So I guess it is card failure. – Shimano Sep 29 '16 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.