2

I'm trying to disable OpenVPN from running at startup. I tried changed the setting for AUTOSTART in /etc/default/openvpn from all to none, but that didn't work.

How do I disable OpenVPN from running at startup?

  • Check the file /etc/init.d/openvpn how it checks the values set from /etc/default/openvpn. Why do you want to disable it at system start? At what time should it start then? – ott-- Oct 4 '16 at 21:11
3

If you are using jessie, check:

systemctl list-units | grep vpn

You should be able to find the name of the service this way (wild guess: openvpn), then:

sudo systemctl disable openvpn

That won't stop it right now, but it should prevent it from starting next boot. You will still be able to start it manually via sudo systemctl start openvpn (and stop it with stop). If you want to re-enable it at boot, use reenable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.