1

I'm trying to set up my Pi as a Plex server and wanted to plug in and mount my storage drive, but it doesn't even start spinning.

I'm using this HDD enclosure (which has its own power source) with a 1tb Seagate Barracuda 7200.12.

The PI is running the latest version of Raspbian.

The drive is NTFS. I haven't tried formatting it partly because there's 400 GBs worth of movies on there, but mainly because the drive doesn't even start spinning, so it didn't strike me as a formatting problem.

Everything works fine on my Laptop and Desktop.

Is the PIs USB power still relevant in this setup, and insufficient?

2

So yeah this was a hardware issue with the HDD enclosure. The USB connector seems to be faulty and only worked if I pulled it out a little.

I bought a different HDD enclosure on Amazon which worked fine. Using the USB cable from the new enclosure with the old one also worked.

Still kinda confused why it worked with my PC and not the Pi, but oh well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.