4

How can I rotate my touchscreen display 180 so that I can stand it up with the power coming out of the top, rather than the bottom as it does now? Thanks (I'm a total novice with Linux so please be gentle)

5

Assuming you have one of these (different size is fine too), they are compatible with/same as the waveshare products available here.

TFT

Using LCD-show drivers and scripts

I have posted the setup details here. As part of the driver bundle there are number of scripts and the instructions to configure the orientations are also available on that site.

Here's an extract

Toggle between LCD and HDMI display Once this LCD is enabled, meanwhile the default settings for HDMI are changed. If you want to use another HDMI monitor, please run the following command:

cd LCD-show/ ./LCD-hdmi

This toggles the mode to LCD display:

./LCD35-show

Screen orientation settings

After touch driver installed, the screen orientation can be set by these commands:

0 degree rotation

cd LCD-show/
./LCD35-show 0

90 degree rotation

cd LCD-show/
./LCD35-show 90

180 degree rotation

cd LCD-show/
./LCD35-show 180

270 degree rotation

cd LCD-show/
./LCD35-show 270

Alternative solution

If the LCD-show script doesn't work for your configuration you can also try and edit the boot configuration manually. That is what these scripts do anyway:

sudo nano /boot/config.txt

Look for a line dtoverlay=waveshare35a or any other display identifier after dtoverlay=. To that line you can append ,rotate= like so:

dtoverlay=waveshare35a,rotate=90

Next exit nano and save changes with ctrl+x followed by Y and ENTER. This requires a reboot to take effect:

sudo reboot

Note that if you're using a touchscreen you'll also have to swap the touch X and Y axis. For more information check this display configuration overview.

  • Yep it's that screen, I tried: cd LCD-show/ ./LCD35-show 180, the screen rebooted as nothing has changed – L Pee Oct 5 '16 at 16:12
  • Success!! I went back and followed the whole process in your link above, and then did the cd ./LCD-show and ./LDC35-show 180 command and it worked! Thank you so much!! – L Pee Oct 5 '16 at 16:22
  • Done! Sorry I'm very new to this :) Again, thank you! – L Pee Oct 5 '16 at 16:45
  • No apologies required, everyone has to start somewhere :) – Shreyas Murali Oct 5 '16 at 16:47
  • This answer got me going on the right track. The rotation values are spelled out here: github.com/goodtft/LCD-show/issues/34 – sberry Dec 22 '18 at 6:19
0

Try adding display_rotate=2 to /boot/config.txt. Reboot required.

Source: https://www.raspberrypi.org/documentation/configuration/config-txt.md


You may also want to try adding lcd_rotate=2 instead of display_rotate=2.

Source: https://www.raspberrypi.org/documentation/hardware/display/troubleshooting.md

  • Unfortunately neither of these options worked :( – L Pee Oct 5 '16 at 14:43
  • This answer only works for the "official" display and not for the mentioned display. – Uwe Plonus Sep 21 '18 at 9:03
0

The Switch between HDMI and the touch Display is done by rewriting all of the config files and Drivers. Try editing the corresponding files behind the LCD35show first.

protected by Community Jun 1 '18 at 11:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.