3

I am having a strange problem.

I just finished setting up my wonderful Raspberry Pi, and it works great, except for the fact that it is not compatible with my wired Mac OSX Keyboard. I can type perfectly well - letters and numbers work fine. But, if I attempt to write ", the output is @. If I write the @ symbol, " comes out. This is extremely annoying - I was hoping to use the Raspberry Pi to test LAN networks in Python, and the " symbol is essential.

How can I remap my keyboard to fix this?

6

NOTE

I found the answer on the official forums. Thank you DancingMan.

Steps

  1. Open Terminal as a root user

    Go to other>X-Terminal as root (GKsu)

  2. Type in the reconfigure command

    dpkg-reconfigure keyboard-configuration
    
  3. Follow the prompts

Hopefully that was helpful - this issue had been bugging me for hours!

1

Also in GUI
Menu
Preferences
Raspberry Pi Configuration
Localization tab
Keyboard (Canada) # in my case!

Then fonts should work correctly

-1

On Raspberry Pi Jesse.

Preferences -> Mouse and Keyboard Settings -> Keyboard tab -> Keyboard Layout -> United States:English(US)

  • 1
    What has "Jesse"(sic) to do with Wheezy? – Milliways Mar 8 '17 at 6:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.