1

I recently bought a Dissolved Oxygen Kit from Atlas Scientific.

First I followed the instruction on the website to connect the device to my Raspberry Pi. This is my final result.

I then followed this guide which shows how to enable the i2c display on the Raspberry Pi.

When I try to run the command sudo i2cdetect -y 1 it should displays the information about the i2c devices connected. However, nothing shows up for me. I tried using another Raspberry Pi, different wires, even another i2c device but it definitely can't detect it.

I run the command sudo nano /etc/modules and added those two lines:

i2c-bcm2708

i2c-dev

I also try using lsmod | grep i2c to be sure that everything is loaded and it is.

What am I missing here?

  • Is that LED green or blue? If it's green then your unit is in UART mode. – joan Oct 7 '16 at 15:40
  • It flashes green, then green and blue and loop. – Antoine Delia Oct 7 '16 at 15:43
  • I thought it was meant to be steady blue if it was set in I2C mode? – joan Oct 7 '16 at 15:46
3

If you are using recent software (last 6 months or so) you should be using device tree.

Add the line dtparam=i2c_arm=on to the file /boot/config.txt.

Remove the line i2c-bcm2708 from /etc/modules.

Reboot.

0

As joan pointed out, it was indeed in UART mode so it is normal I could not detect it. More info here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.