5

I bought this wifi adaptor from Adafruit (RTl8192cu chipset). I plugged it directly into the raspberrypi and started it up. But I didn't have the wpa_gui app and I guess I didn't have the latest raspian so I tried to get that upgrade first.

I ran

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install raspberrypi* raspi-config

And then I followed the instructions on this page up to the create netdev user step. But I still don't see any adaptors listed when I launch WPA_GUI. I really thought this thing would be plug and play :-( The Adafruit site seemed to imply that ...

Can anyone help? I'm really not good at hardcore Linux hacking.

7
  • what does the command lsusb show? My unit displays as Bus 001 Device 004: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter Mar 25 '13 at 17:39
  • Yes, I see exactly that.
    – Greg
    Mar 25 '13 at 20:05
  • Other things I noticed: WPA_GUI in the status area says "Could not get status from WPA_SUPPLICANT"
    – Greg
    Mar 25 '13 at 20:06
  • Also a message I saw flash by when it was starting up: "couldn't read interfaces file: /etc/network/interfaces". I wonder if that means something?
    – Greg
    Mar 25 '13 at 20:15
  • 1
    Are you running the WPA_GUI as root? i.e. wudo WPA_GUI I setup mine manually using the command line. Mar 25 '13 at 20:19
2

Yay I got it working! It turns out I had a line split over two lines in the interface file. That's what I get for copying the settings from my phone!

Thanks for all the help.

1
  • I have exactly the same issue as you right now, with the same adapter according to lsusb. What does your /etc/network/interfaces file look like? I think mine's fine, but I can't be sure. Very frustrating! Jul 25 '13 at 18:09
0

in my case I had a line starting with wpa-roam while it should be wpa-conf in my /etc/network/interfaces file. After I changed it and did ifdown wlan0 && ifup wlan0, the adapter appeared

i was following this tutorial for the rest of the interfaces file, btw: http://weworkweplay.com/play/automatically-connect-a-raspberry-pi-to-a-wifi-network/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.