0

I was using my Pi 3 on an 10-year old Linksys wifi router, and it worked fine. However, I just bought a new Linksys router, which supports 802.11 A, C and N, and all my devices are able to detect and connect to the new router...except the Pi3. Running nmcli dev wifi doesn't show my SSID, even after rescanning.

According to the specs, the Pi3 supports only 802.11N, so it should "just work".

Is there any kind of configurations that the Pi3 doesn't support?

For example, my router's admin lists my wireless network settings such as:

wireless network mode: mixed
channel width: Full (20 MHz)
wireless channel: auto
security mode: WPA2 Personal
WPA algorithms: TKIP+AES

It has two interfaces:

  1. 5 GHz/802.11ac
  2. 2.4 GHz TurboQAM
  • The Pi does not support 5GHz, and by default not channels 12 or above. – Milliways Oct 14 '16 at 5:25
  • Even if I set the 2.4 GHz interface to "N-Only" and set it to a fixed channel like 5, it still doesn't work. – Cerin Oct 14 '16 at 13:37
1

The problem turned out to be a bug in my router. When the wireless security was set to "TKIP+AES", it stopped broadcasting the ESSID, although I could still see the network via the MAC address from the Pi. Changing the algorithm to just use "AES" fixed it, so this wasn't a problem with the Pi.

  • Please share the model of your new router to inform people. – vaha Oct 14 '16 at 16:08
  • This was on a Linksys WRT1900 ACS v2 running DD-WRT. I only tested it when running DD-WRT, so I don't know if the stock Linksys firmware also has this problem. – Cerin Oct 14 '16 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.