I downloaded and dd latest image of Raspbian Pixel on sdcard of Raspberry Pi 3. I activated VNC interface from Menu> Preferences> Raspberry Pi Configuration. Raspberry Pi is connected to the wifi and I access it on my iPad mini using VNC Viewer app. Also no HDMI is connected to Pi.

Now the problem is I only get resolution of 656x416 which is too small for doing stuff. Since I didn't manually edit any file using terminal, I don't know how to increase it. I think I need to edit a vnc file and pass parameters. Please help me fix resolution.

  • Hi. Please select an accepted answer for this :D – ppumkin Mar 20 '17 at 12:36
up vote 20 down vote accepted

Found a fix, edited /boot/config.txt

enabled these configs:

framebuffer_width=1280
framebuffer_height=720

Note - on some versions of Pixel you may need to create this file as it may not exist. For example using a Kali Linux version and this file did not exist but worked for a headless implementation once created after a reboot.

In the desktop menu, go to Preferences > Raspberry Pi Configuration and click the "Set Resolution" button. Or, from the terminal, run sudo raspi-config and choose Advanced Options > Resolution.

If you have a monitor attached, it will show a list of modes supported by the monitor. If you don't have a monitor attached, it will show a list of the most common modes.

If you want a mode that isn't listed, you will need to edit /boot/config.txt as described here: https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

You will need to reboot your Pi for the new mode to take effect.

Increase frame buffer in configs file:

sudo nano /boot/config.txt

by uncommenting these lines:

framebuffer_width=1280
framebuffer_height=720

and then

sudo reboot
  • 1
    Is this the same answer as from Karanvir? – ppumkin Mar 20 '17 at 12:35

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.