0

I could install a Web Application on my laptop both on Ubuntu Linux and Windows without any problem. But When I tried to install it on raspberry pi 3 raspbian platform I got such a problem.

enter image description here

I tried both versions of setup file, 32 bit and 64 bit. I checked java version. But I could not figure out what is missing.

  • 1
    Pure java is portable to the Pi as is, but if the application comes in 32 and 64-bit versions it contains JNI code and as per vaha's answer, unless it specifically says "ARM" assume these bits are compiled for an x86 (Intel/AMD) based machine. It won't work. This doesn't explain the odd characters in the output but that may be coincidental. – goldilocks Oct 18 '16 at 9:06
  • @goldilocks The weird output is consistent with a binary file being interpreted as a shell script. – Thorbjørn Ravn Andersen Jan 17 '17 at 12:27
1

You cannot execute binaries compiled for x86 architecture on arm processors.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.