2

Raspberry Pi 2, Model B Latest Raspbian Jessie - Headless

I have spent literally weeks of my spare time trying to debug this - so naturally, it's probably a simple problem I have mucked up.

I have tried multiple fresh installs, I now have access to my Pi through ssh over the wireless dongle I plug in.

The Pi's ethernet seemed to work on another persons install of Kodi, however it hasn't worked for me with Raspbian Jessie Lite, Raspbian Jessie, Raspbian Wheezy.

When I turn on the Pi the lights come on on the ethernet, both lights, the green light flashes intermittently at random intervals. SOMETIMES, when plugging in an ethernet cable, the light will flash for a while - but if anything it will just go to this random IP it has tried to set itself.

Files for perusal:

                                   File: /etc/network/interfaces                                                                              

# interfaces(5) file used by ifup(8) and ifdown(8)
# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet static
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

/etc/wpa_supplicant

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="Healing Center"
        psk="*******"
        id_str="guy"
}

network={
        ssid="ChediView3"
        psk="********"
        id_str="Chedi3"
}

ifconfig -a

eth0      Link encap:Ethernet  HWaddr b8:27:eb:ff:9c:48  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:71 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:12431 (12.1 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:876 errors:0 dropped:0 overruns:0 frame:0
          TX packets:876 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:70524 (68.8 KiB)  TX bytes:70524 (68.8 KiB)

wlan0     Link encap:Ethernet  HWaddr 40:a5:ef:07:f2:d4  
          inet addr:192.168.1.6  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::bdc8:3907:baea:c245/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9284 errors:0 dropped:3694 overruns:0 frame:0
          TX packets:3911 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2006150 (1.9 MiB)  TX bytes:1610126 (1.5 MiB)

(at the moment there is no IP showing)

dmesg|grep eth0

[    3.930077] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:ff:9c:48
[    9.867363] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[    9.867552] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   11.390454] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   11.391527] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x4DE1
[   28.760723] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   28.838301] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   28.990076] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   29.077783] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   30.600737] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x4DE1
[   35.898452] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   35.969400] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   37.493017] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x4DE1

So I know there are lots of questions related to this on the internet, but trust me, I have tried and tried and tried! I feel like there is something out of the ordinary happening, my assumption would be that the ethernet jack is faulty, however it does seem to have worked on the other installation of Kodi.

Thanks in advance for any help.

  • Have you tried just bringing up eth0? sudo ifup eth0 – Ian M Oct 20 '16 at 10:11
  • Yes. No success. – Kennedy Baird Oct 20 '16 at 13:10
  • Are those your real passwords? If so, you should change them. If you can't, raise a moderator flag to have them removed from the history. – Dmitry Grigoryev Jul 10 at 6:38
1

You've included your /etc/network/interfaces but newer installs of Raspbian use dhcpcd so could you add /etc/dhcpcd.conf?

You can bypass dhcpcd by changing this:

iface eth0 inet manual

To this:

iface eth0 inet dhcp

and it should switch to using /etc/network/interfaces Find more information here: dhcpcd vs /etc/network/interfaces

  • I'll check this tomorrow and get back to you! Thanks – Kennedy Baird Oct 20 '16 at 13:12
1

If you are going to put random rubbish in your config files, you can't expect it to work.

First you should revert to a standard Raspbian Jessie, forget Wheezy, which is obsolete, and Jessie Lite (unless you have some particular reason).

Ethernet will then work out of the box, with no configuration, assuming you have a normal router with DHCP. You will have to configure WiFi if you want to use it. See How do I set up networking/WiFi/Static IP for suggestions on how to do this.

If you need further help after this describe your network. Generally you should decide to use WiFi or Ethernet, not both.

  • I stated in the initial post that I have tried multiple operating systems. – Kennedy Baird Oct 20 '16 at 13:10
  • Naturally I first tried Raspbian Jessie lite, because I wanted a headless install. Downloaded from the official sources. Then when that didn't work, I tried Raspbian Jessie, which also didn't work, then I thought - hey maybe because this is an older pi, and older Raspbian would work, so tried a Raspbian wheezy ISO. – Kennedy Baird Oct 20 '16 at 13:11
  • But now I am on Raspbian Jessie lite. – Kennedy Baird Oct 20 '16 at 13:12
  • Further more, I have tried on multiple networks, using multiple Ethernet cables. All networks using auto DHCP assign – Kennedy Baird Oct 20 '16 at 13:36
  • The problem IS that using clean installations of up to date official Raspbian distros, that the Ethernet didn't work out of the box. Hence me spending lots of time fiddling and trying other things. Even after running dist-upgrade and bring up to date the Ethernet doesn't work. – Kennedy Baird Oct 20 '16 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.