2

I'm a recent RPi user.
Pi version - Pi 3, Model B
Bluetooth speakers - Philiphs BT64R

I've tested the speakers with other devices and the bluetooth pairing works fine. I've also tested my Pi with other devices and the pairing works fine too. Bizarrely, I can't get my Pi connected to the speakers.

Here's the trace:

pi@raspberrypi:~ $ bluetoothctl -a
[NEW] Controller B8:27:EB:6E:90:94 raspberrypi [default]
[NEW] Device F0:24:75:F0:7B:8C XXX's iPhone
[NEW] Device FC:58:FA:DC:9F:12 PHILIPS BT64
Agent registered
[bluetooth]# info FC:58:FA:DC:9F:12
Device FC:58:FA:DC:9F:12
    Name: PHILIPS BT64
    Alias: PHILIPS BT64
    Class: 0x260404
    Icon: audio-card
    Paired: yes
    Trusted: yes
    Blocked: no
    Connected: no
    LegacyPairing: no
    UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
    UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
    UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
    UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
[bluetooth]# pair FC:58:FA:DC:9F:12
Attempting to pair with FC:58:FA:DC:9F:12
Failed to pair: org.bluez.Error.AlreadyExists
[bluetooth]# connect FC:58:FA:DC:9F:12
Attempting to connect to FC:58:FA:DC:9F:12
[CHG] Device FC:58:FA:DC:9F:12 Connected: yes
Failed to connect: org.bluez.Error.Failed
[CHG] Device FC:58:FA:DC:9F:12 Connected: no
[CHG] Device FC:58:FA:DC:9F:12 Connected: yes
[CHG] Device FC:58:FA:DC:9F:12 Connected: no
[bluetooth]# 

I am not using Blueman. I tried it and then I couldn't connect to any device via bluetooth so I decided to try without it.

Thanks.

0

If you're connecting to an audio device, this could be happening for various reasons:

  • Pulseaudio is not running (use pulseaudio --start)
  • The appropriate module is not installed (use apt install pulseaudio-module-bluetooth)

See https://unix.stackexchange.com/questions/258074/error-when-trying-to-connect-to-bluetooth-speaker-org-bluez-error-failed for more info

-1

you need install pulseaudio and enable each time it by 'pulseaudio -D', then you can connect your bt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.