0

I bought a brand new RBPi 2 (Model B) Starter Kit that includes a power adapter, cable and 16GB SD card.

I want to install Ubuntu Core which I have followed their tutorial exactly using Mac but the Pi doesn't boot.

The OS is installed on the SD Card perfectly fine (as according to the tutorial) but when I plug the power in then after about 30 secs I go into like a boot-loop. WATCH VIDEO

Just loads up the logo and a list of setup functions but then 'bombs' out and repeats. Looked around on the internet but nothing seems to resolve this issue.


What I've tried:

  1. Tried installing Raspbian but the situation is worse (just shows RSPi logo then 'bombs' out)
  2. Tried other cables and power adaptors (inc. iPhone and Android plugs) but produce same results.

An idea is that maybe the voltage is too low? Im unable to check the voltage as I currently don't have one but its plugged into the mains with the power adapter and cable it came with; Wouldn't that already be enough power?

I am completely new to this so apologies. Any help is appreciated.

  • If you could add some specs about the adapter the pi came with and a photograph. – goldilocks Oct 20 '16 at 14:22
  • @goldilocks I wish I could of but there was a 2 links only limit until I got to rep 10 – DocAsh59 Oct 20 '16 at 14:48
  • Drop it into a comment here and I'll edit it in. – goldilocks Oct 20 '16 at 14:49
  • Actually ixnay that -- sounds like you worked it out. – goldilocks Oct 20 '16 at 14:50
2

In the official documentation you have some specifications about the required power.

For checking the voltage, check to the red led of the raspberry. It must not blink when booting. If you see that the red led blinks sometimes, that means that your voltage is not correct and you must use a different the adapter. Also, I recommend to check the adapter. Not all of them generates enough amperage (specially if you are using a recycled adapter from an old mobile phone)

Also in this raspberry that has bad power supply (where I have installed OSMC), if I have the TV started and connected to the HDMI of the raspberry, the green led freezes and the raspberry does not start. I need to start first the raspberry and later the TV. Otherwise the video test freeze my raspberry. I almost sure that this case is due to an insufficient power supply.

  • Thanks for that. I've just checked and when the list of setup functions begins (see video in question) the red light does blink a fair bit. I will try couple of other adaptors, if not i'll buy a new with the at least required voltage. – DocAsh59 Oct 20 '16 at 14:14
  • I have three raspberries, and one of them has a "no so good" adaptor. My red led blinks, but still works. Of course, I would not recommend to attach any usb stick or other usb peripherals to this raspberry that needs some energy. – King Midas Oct 20 '16 at 14:17
  • The little rainbow square in the upper right hand corner of that video is also a low voltage indicator. That it is on solid is not a good sign. The kernel won't trigger a reboot like that; when it fails it just stops and the machine hangs. This implies it has reached a point where it is maxing out the processor (the kernel is likely the first thing to do this for any amount of time) which would be when current draw peaks, causing the voltage to drop further to the point where the hardware shuts down, then the current draw relaxes, the voltage goes back up, and it starts up again. – goldilocks Oct 20 '16 at 14:19
  • @JorgeHortelano I've noticed with a Pi 3 the led flickering and intermittent rainbow square flickering also when using a USB power bank as a supply. It doesn't seem to be a problem, but I haven't done it that much. The rainbow square coming on immediately and staying on in that video looks worse. – goldilocks Oct 20 '16 at 14:21
  • I only have a raspberry 2 and 1 (B). But yes, an small rainbow square is not a problem, it disappears when booting after the vga has been tested. If you have a big one then sure it is a power supply problem and cannot boot the raspberry. – King Midas Oct 20 '16 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.