1

Im having a hard time pinpointing why my RPi2 have such a terrible NFS read performance. Background: Using openelec or Libreelec i cannot read large BD-rips file structures without having heavy framejumping/freezes etc.. So i started the investigation.

  1. RPi2 is running 4.7.6 Linux Kernel
  2. Via ethtool i have confirmed that it has infact negotiated it self to 100mbps against my switch port
  3. My Synology NAS 414j can easily pump out 40-70mbps depending on the client
  4. All my switches are 1gig
  5. Using dd=file.foo from the nas to my RPi2 of=/dev/null gives me consistant NFS read performance at around 700KB/s
  6. Using iostat iowait is hovering around 22-30% during the dd transfer and as well as under BD file views.
  7. Ive overclocked all parts on the RPi2 to see if that would help... it doesnt..
  8. Using these mount options doesnt fix it either:

mount -t nfs 10.100.10.91:/volume1/Video /storage/MOVIES2 -o udp,noatime,rsize=32768,wsize=32768,nolock,nfsvers=3

Linux LibreELEC 4.7.6 #1 SMP Fri Oct 7 18:36:25 BST 2016 armv7l GNU/Linux

  1. The strange thing is that it worked a few months ago and on my other mediaboxes with better HW, this aint an issue...

Soo..... anyone have any idea what can be the culprit?

UPDATE: I installed the latest fedora 25beta for Arm on another SD, rebooted and redid the tests... and with standard mount default parameters.. guess what: 10,7MB/S with 15% iowait... I redid the tests 5 times.. all with the same result.. so the conlusion is: LibreELECs busybox OS disto is fuubar.. no idea where tho..

br TE

  • The USB ports and Ethernet port are connected to the same controller on the Pi. This means it has to deal with 2 streams of data when something is read from the hard drive and then sent over Ethernet. This will most likely be your bottleneck. – Darth Vader Oct 22 '16 at 7:38
  • @DarthVader Not enough so to explain that -- and I think the hard drive isn't on the Pi, this is an external NAS. Writing to /dev/null it should be able to do that at 8-10 MB/s. – goldilocks Oct 22 '16 at 13:40
  • the NAS (networked attached storage) by its definition is via the network ;) So no local discs here.. – TEB Oct 22 '16 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.