0

I just bought a PiGlow and a Pibrella, and I was curious how it worked. I imported a few Python scripts from this link, but none of the scripts does work. When I run one of the scripts, I get the error:

Traceback (most recent call last):
  File "/home/pi/piglowtest2.py", line 1, in <module>
    from piglow import PiGlow
  File "/usr/local/lib/python3.4/dist-packages/piglow.py", line 1, in <module>
    import sn3218
  File "/usr/local/lib/python3.4/dist-packages/sn3218.py", line 112, in <module>
    enable_leds(0b111111111111111111)
  File "/usr/local/lib/python3.4/dist-packages/sn3218.py", line 60, in enable_leds
    [enable_mask & 0x3F, (enable_mask >> 6) & 0x3F, (enable_mask >> 12) & 0X3F])
OSError: [Errno 5] Input/output error

I'm using a Raspberry Pi 3B. Is there a change in the modules of Python? Can anybody help me?

Thanks in advance.

This is the Pi with the Piglow:

The Pi with the Piglow

  • Probably you should add a photograph of your connections. – goldilocks Oct 22 '16 at 15:29
  • @goldilocks I did, as you can see. – L. Peters Oct 22 '16 at 18:02
  • Does that fit on all the way down with the case in the middle like that? Also, if that is I2C based did you enable I2C? If so how? – goldilocks Oct 22 '16 at 18:15
  • @goldilocks yeah I did check it and it said that my IC2 is enabled. – L. Peters Oct 22 '16 at 18:17
  • That's not what I meant by "how". It's your problem and it is up to you -- if you are convinced you've done everything right so you don't need to bother explaining anything other than the fact that it still doesn't work, this seems like, "Does this prove something is broken?" (no) and not "What might I have done wrong?" – goldilocks Oct 22 '16 at 18:22
1

You are missing the module piglow.

I suggest you google for "Raspberry Pi Python module piglow" and see if you can find the module together with installation details.

  • @L.Peters github.com/Boeeerb/PiGlow has detailed instructions. At which stage did you receive errors? – joan Oct 22 '16 at 13:36
  • I downloaded the module, but then I get another error: it has got a lot of text (to much for a comment) but it's an OSError: [Errno 5] Input/output error – L. Peters Oct 22 '16 at 14:08
  • That error suggests the PiGlow is not connected to the I2C bus properly. It sounds like you have now installed the piglow module and have a new, different, problem. A new, more targeted question may be appropriate. – joan Oct 22 '16 at 14:15
  • I fixed the question :) – L. Peters Oct 22 '16 at 14:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.