2

this is my first post on this SX Forum.

After doing some searching myself (and failing), I wanted to ask why the command sudo apt-get build-dep emacs24 fail on a Pi running Raspbian Jessie?

The output I receive is the following error: E: You must put some 'source' URIs in your sources.list

What I am wondering then is:

  1. Why doesn't Raspbian's deb and deb-src not have emacs24's dependencies upstream from Debian?
  2. Is there another way to enable the command for emacs24? If not, how can I find all the dependencies needed for building emacs without X Windows (aka GUI) support?

    Thanks!

4

My system config is

Linux raspberrypi 4.4.13+ #894 Mon Jun 13 12:43:26 BST 2016 armv6l GNU/Linux

Please follow the below steps and it should get things ready for you.

1. sudo vi /etc/apt/sources.list
2. Un comment the line 
   deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi

Now the file will look like

deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source' 
deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi

Perform a sudo apt-get update

Now your command sudo apt-get build-dep emacs24 should work. Its just enabling the builds from deb-src doing the trick.

  • 1
    I wish all Linux distributions had source repositories configured by default. I am not sure if there is a huge downside if they did. The ability to quickly download and read the exact source (including any distro patches) of a package that is present on my system is immensely useful. – sigjuice Oct 25 '16 at 5:45
  • Can confirm it also works for Raspbian Stretch – Dante Sep 21 '18 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.