0

Getting the below connection refused when trying to SSH to my Pi (have also tried with correct IP):

$ ssh raspberrypi -l pi 

ssh: connect to host raspberrypi port 22:Connection refused

Only having a laptop I need to setup my Pi headless from scratch, found many instructions that imply you don't need to enable SSH. You can just chuck the Raspbian image on SD, power up, plug the Ethernet cable in to the router, find it's ip & then ssh/putty in.

Are instructions like this (Setting up a headless Raspberry Pi as a Music Player Daemon server) out of date & SSH is no longer enabled on current Raspbian images?

Here's my set-up:

  • 2016-09-23-raspbian-jessie.img
  • 16GB micro SD
  • Pi 2 Model B
  • Windows 7
  • Cygwin with OpenSSH & additionally Putty (both generate same connection refused error)
1

You can ssh into a Pi, however you need to specify the IP address. raspberrypi.local may find the address if your system supports Zero-conf

0

You might need to use the actual IP address if your local DNS is not sufficient. You can find this by logging in to the admin section of your router(broadband maybe) and view connected devices. This is your DHCP server.

If you do not have access to the the DHCP server you can open a command line and use arp -a. This uses the Address Resolution Protocol. You may be able to identify the correct IP from the resulting list.

0

If you have a lot of different SSH keys loaded, it's possible you may be blowing through the default MaxAuthTries without realizing it. To check if that's the case, try disabling the public key piece:

ssh -o PubkeyAuthentication=no username@yourpi

If that was the culprit, then you can either increase the MaxAuthTries on the Pi in /etc/ssh/sshd_config, or adjust your ~/.ssh/config to use IdentitiesOnly yes for all entries. Or, if you just have a number of ssh identities that you want to clear out, ssh-add -D will clear them out.

0

Thank you all for replying, all valid points but had as stated tried with the ip address too.

Not sure what fixed it but here's what I did....

Full format of sd card, manully removing the volumes in place first via the windows 7 device manager. Placed the current raspian jessie lite image on the sd card Powered up the pi & was then able to SSH in first time...

Thanks again, really appreciated all the input

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.