3

We would like to use Gertbot card on Raspberry Pi 3 to control motors and to read distance sensors. For that, serial communication using UART0 on GPIO pins 8 and 10 is required. Observing Raspi serial output with a PC showed that only garbage is transmitted via UART0. Baud rates, stop bits and other serial setup are identical in both the ends. Googling revealed that Raspi 3 has kind of replaced UART0 with Bluetooth which disturbs serial communication (see the link below).

Pi 3 Boot with UART console

That is:

  1. How to disable the Bluetooth device on Raspi 3 + IoT Core?
  2. If we manage to disable Bluetooth, is some manual GPIO remapping also required to restore correct UART0 functionality?

Googling did not take me any further (there are only results about how to disable Raspi Bluetooth on Linux). Also, there seems to be no option to disable the Bluetooth device using the graphical Windows Device Portal UI although I can discover some Bluetooth device information there.

  • 1
    As no solutions have been suggested, we decided to buy a Raspberry Pi 2 instead. Now, the UART communication works as expected. – Petri K Nov 3 '16 at 5:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.