0

I successfully installed Raspbian on my RPi, and tried to connect wifi on my room, but it's not working.

If I connect non-password wifi (maybe my neighborhood's), It's working well.

But, mine has simple password (abcd1234).

I clicked my wifi and input the password, and click 'OK' button, no changes. none of message dialog.

I changed my wifi setup [WPAPSK/WPA2PSK] to [WPA2PSK], and tried again,

but couldn't solve the problem.

Is there other way to connect to my WiFi?

  • What channel is your WiFi using? I don't know supported channels for Korea (if you are in Korea), but a lot of people have had problems with the on-board WiFi of the Pi3B, because it is much more particular about the supported modes. sudo iwlist wlan0 channel will show what channels are supported. – Milliways Oct 30 '16 at 6:50
  • @Milliways My WiFi channel was 11 (before I fix the problem). and I changed using country, The channel is now 9. – Juntae Oct 30 '16 at 7:32
  • and sudo iwlist wlan0 channel during wifi connection, It said 1~11 channel available. and without connection, It said 1~13 channel available. – Juntae Oct 30 '16 at 7:33
1

I solved the problem,

I don't know why, but it is related with WiFi configuration.

I access to 192.168.0.1 for wifi setup (On my Windows Desktop), and change "using country(사용국가, 使用國家)" Korea to US, and it's working.

0

I had the same problem, in "Dutch" mode. I have reset the localisation to GB, but it didn't help for me. Then, I have re-installed the complete system, making sure the language is "GB" from the NOOBS-installation-screen. After this, I could enable wlan0 from the icon without any problem.

-1

There have been updates to pixel so try this: sudo apt-get update sudo apt-get dist-upgrade

  • 1
    These commands won't update pixel, they will update the OS to a newer version. – tlhIngan Oct 31 '16 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.