1

I have this raspberry PI 2, which I run Resilio and SSH for backups. I installed a couple of stuff without any issue (APCUPSD, web interface for APCUPSD, apache2).

I am trying to install RPI-Monitor and webmin, but I always get: E: Unable to correct problems, you have held broken packages.

 Depends: libnet-ssleay-perl but it is not going to be installed
          Depends: libauthen-pam-perl but it is not going to be installed
          Depends: libio-pty-perl but it is not going to be installed
          Depends: apt-show-versions but it is not going to be installed

if I try to install them, i get this message:

The following packages have unmet dependencies:
 apt-show-versions : Depends: libapt-pkg-perl (>= 0.1.21) but it is not going to be installed
 libauthen-pam-perl : Depends: perlapi-5.14.2
 libio-pty-perl : Depends: perlapi-5.14.2
 libnet-ssleay-perl : Depends: perlapi-5.14.2
E: Unable to correct problems, you have held broken packages.

Any help would be appreciate.

Thanks

  • Try sudo apt-get install -f – ElefantPhace Oct 31 '16 at 0:48
  • Can you please give also the command line you use to install? – Uwe Plonus Mar 19 '18 at 9:42
1

Try running these commands:
sudo apt-get clean && sudo apt-get update && sudo apt-get upgrade (assuming you have sudo access)

source:Linuxquestions.org

  • link – NerdOfCode Nov 1 '16 at 11:52
  • sudo apt-get clean && sudo apt-get update && sudo apt-get upgrade Please edit your answer, for best reading – abkrim Jul 17 '17 at 7:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.