1

I have formatted my RPI3 SD card to run the new Raspbian OS (with new skin and such). The problem is that I used to run Emulationstation on that SD card; so I did try to install it manually, instead than running the Retropie image directly.

The problem is that at boot, the X server start, even if I set it to not start (in the raspi-config util); and then it quit to terminal, but when I run emulationstation command, I get an error that say that X is running and I need to shut it down.

So I did log in at boot, and launched the desktop environment; then I did logout via the menu, and still I get the same error saying that X is running.

How do I get the RPI to start in console directly, without start the desktop process, so I can run Emulationstation directly at boot? And why "startx" does not work anymore, once that I am in console? The only way to get to the desktop seems to be to reboot the PI.

2
  • Asked and answered here: raspberrypi.stackexchange.com/questions/1318/…
    – SDsolar
    Nov 1, 2016 at 6:30
  • Sadly it is neither the right question nor the right answer. I am aware of how to set the boot flags to get directly in X server, the issue is that it won't take the command to start X. Also the main question is how do I turn off X, once that I do log out from it; because it doesn't seem to shut down unless I kill the process by hand
    – rataplan
    Nov 3, 2016 at 0:00

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.