1

I haven't used my Raspberry Pi 2 B for about a year and when I tried booting it today it doesn't work. Last time I used the Pi it worked but now it only displays the green light (no blinking). I'm using the same charger that I used before and I haven't used it since the last time I was on the Pi.

I tried connecting the charger without the SD card but it still only displays the solid green light.

Is there anyone who have experienced something similair and knows how to fix it or is the Pi broken?

migrated from stackoverflow.com Nov 1 '16 at 20:20

This question came from our site for professional and enthusiast programmers.

  • This site is for programming questions. We are not general hardware tech support. – Marc B Oct 31 '16 at 20:47
  • Check your SD card image - download and install a new one if needed. It doesn't make any sense to test the Pi without an SD card. – dbmitch Nov 1 '16 at 3:41
  • The green is on but the red is off? The voltage is possibly too low, or the pi has been damaged. The red PWR led should come on. – goldilocks Nov 1 '16 at 22:07
1

If you haven't tried this already, hook it up to a display, not just SSH or VPN, because it may not get that far in the boot process. Then on another (if possible, new) SD, install a fresh OS image, raspbian or noobs probably. Try to boot from that while the monitor or tv is hooked up to the RPi (make sure if its a TV it is on the right input). If it is black, there is a very bad problem. If it works perfectly, than the other SD is bad or the OS on it is corrupted, I've had both happen before. If the OS is corrupted, it's possible to restore some of the data. If nothing recognises it, like if another linux machine doesn't . If something shows up, but it does not run normally, post any error messages you can find. If it is black or there is a booting error, try using a multimeter to check the charger amperage. It needs to be minimum of 600 mA according to RPi B+ docs, but I have found 1500 mA to be much more reliable, sometimes even necessary if using GPIO. Check it with the multimeter, not just looking at the label, it may be a bad power supply. Many phone chargers do not supply adequate power. Most all Apple chargers do, but other USB adapters often do not. If you want to buy a cheap power supply, I recommend the official one. I have it and it works great, even powering a small cooling fan. Next, check the voltage of the power supply with the multimeter. It should be near 5 volts.

  • If only one LED is on, you know for certain that it isn't booting far enough for SSH/VPN. – Mark Nov 1 '16 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy