0

Sometimes when I try to download some torrents with my raspberry pi via transmission, my raspberry pi slows down a lot. During such times I can not view the progress with transmission-remote -l as the procedure call times out. Doing anything else like removing the torrent is mostly futile.

The same happens when I am using vnc and transmission-gtk.

I have also noticed that during the problem I am unable to enter the destination folder due to lag. The destination folder is on a USB HDD with an NTFS filesystem.

Generally after a while the transmission-daemon just crashes and suddenly I can use my raspberry pi again.

  • 1
    Are you using SSH to issue commands, or is the Pi connected to a screen and keyboard? – goobering Nov 2 '16 at 22:25
  • 1
    What is the rating of the power supply to the PI and the USB HDD ? Operating near the full capacity of the power supply could cause some stability issues. you could try reducing the load by using an externally powered USB hub in between the pi and the USB HDD and checking if the problem goes away – Shreyas Murali Nov 3 '16 at 3:48
  • 1
    Have you tried limiting download speeds to arpox a half meg? – Mohammad Ali Nov 3 '16 at 16:27
  • @goobering Yes I am using ssh. – Mario Kamenjak Nov 5 '16 at 8:22
  • @ShreyasMurali It is connected to an usb hub with external power supply – Mario Kamenjak Nov 5 '16 at 8:23
2

You're swamping your network connection.

When you start your torrents your torrent client software will (usually) try to download them as quickly as possible. In doing so it's using all of the Pi's available network capacity, leaving insufficient capacity for doing useful things like sending SSH session data. Per Mohammad Ali's comment above you should limit your download rate (and probably upload rate as well) to allow enough spare bandwidth for your SSH session to work properly. You should be able to edit the configuration by entering:

sudo nano /etc/transmission-daemon/settings.json
  • I don't get it. I tried limiting the download speed and still the same. I also checked the power supply on the USB hub, it's rated with 2a which is obviously good enough for the hard drive to work. Sftp works better than bittorrent. – Mario Kamenjak Nov 11 '16 at 14:58
  • I think that's my best guess I'm afraid. It's worth ruling out completely by really limiting your torrent up and down speeds to something ridiculous like 5k/sec and re-testing. If your issue is bandwidth related then this should fix your problem, and you can adjust up in small amounts till you find something workable. If it's not bandwidth related, it won't do anything and you'll still experience issues. If that's the case it might be worth looking at a different torrent client, or investigating power issues. – goobering Nov 12 '16 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.