0

After following this post - http://blog.scphillips.com/posts/2013/07/playing-music-on-a-raspberry-pi-using-upnp-and-dlna-revisited/

Raspberry pi would not show up in the bubbleupnp rendered list.
After configuring gmrender, I installed the app in android running kitkat, but in the renderer list it only shows "Local media render".
How to diagnose this?

PS - Goal - Simply stream mp3 files in the phone to raspberry pi.
PPS - I have assumed when I power the PI and login, I would just need to open the app, connect and stream music.

EDIT

running this ./src/gmediarender -f "My Renderer"

results

gmediarender 0.0.7-git started [ gmediarender 2016-10-22_57dfbfd (libupnp-1.6.19+git20141001; glib-2.42.1; gstreamer-1.4.4) ].
Logging switched off. Enable with --logfile=<filename> (e.g. --logfile=/dev/stdout for console)
gmediarender: output_gstreamer.c:503: output_gstreamer_init: Assertion `player_ != ((void *)0)' failed.
Aborted

What does this mean? Is this to be ignored if you go by the tutorial blog post setup.

1 Answer 1

1

I had the same problem here with my orangepi boad.

It was fixed by installing manually all the gstreamer1.0-* binary dependencies suggested in the blog post you linked.

I also had to change some parameters in /etc/default/gmediarender:

ENABLED=1
DAEMON_USER="pi"

If it still does not work try with a fixed IP:

DAEMON_EXTRA_ARGS="-I 192.168.42.79"
1
  • I would keep this in my knowledge base. I got it to work simply by rebooting and reconfiguring the wifi settings in my router as well. I don't know how it worked but later when trying on another SD card, instructions from the blog worked straight up 1st time.
    – arjun
    Jan 26, 2017 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.