6

Using LibreELEC v7.0.2 with Kodi 16.1 on a Raspberry Pi 3.

The date and time is incorrect. It can temporarily be fixed by SSH'ing and running date --set with a provided date. But on boot, the date resets to the date when Kodi was compiled: June 22 2016.

As far as I can tell, there is no option to fix the date in Kodi. The most you can do via its UI is to choose your region and timezone.

Tried SSH'ing and having the datetime synced via ntpd but it's not possible to configure a list of servers in a /etc/ntp.conf file as the file system is read-only.

How can you set the correct date on LibreELEC?

6

Figured out how to set the correct date and time from within Kodi.

  1. Go to "LibreELEC Settings"
    • From the main menu: Programs -> Add-ons -> LibreELEC Configuration
  2. Go to the "Network" tab
  3. Add some time servers under the "NTP Servers" section
  4. Set "Wait for network before starting Kodi" under the "Advanced Network Settings" section
    • The default "Maximum Wait Time" will be 10 seconds
6

Settings > Interface > Regional > Timezone country ( > Timezone)

  • Note for UK users: Timezone country is 'Britain (UK)' which I missed the first time and was confused, expected it to be under 'UK' or 'Great Britain'. – Nick Baker Apr 27 at 11:39
1

Settings > Interface > Regional > Timezone country once the country is set, you should see the word Timezone change from being grayedout to white. then click on Timezone > your area.

For me it's Timezone Country > United States, Timezone > America/Bosie, since I live in Idaho.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.