6

So, I just installed win10 IoT dashboard (on my windows 10 pc) And I wanted to set up a new device. The problem I encounter is that when writing the image to the sd card, I simply get an error that states

Failed to write provisioning file to the microsd card

And that's it. No other info.

How can I find out what's wrong and fix the error?

  • 1
    Have you tried using a different SD card? How are you writing the image to the SD card? – Darth Vader Nov 5 '16 at 16:18
  • I did try a different sd card - same result. I am writing it via a usb stick, that I insert the card into. This usually works when I flash something else to the card (other raspberry OSes) – Mario Stoilov Nov 6 '16 at 12:57
  • I also ended up putting noobs on the sd card and installing win10 IoT via it – Mario Stoilov Nov 6 '16 at 12:58
  • Hi Mario. Can you please answer your question. It seems like a SD card problem? But also how you solved it would be amazing (by using Noobs) Thanks – Piotr Kula Dec 5 '16 at 10:52
3

So, Just to answer my question and give some hints to people that may have the same problem:

A new SD works, but if you format it with the official SD formatter tool, that somehow breaks all following attempts to install windows 10 IoT via the IoT dashboard (tested with 2 new SD cards, and any following formatting with other tools do not fix this).

If by any chance you did break your sd card with SD formatter, you can install NOOBS on it, which can download windows 10 IoT on it. The only difference between NOOBS and dashboard installation is that with NOOBS you have to configure the passwords/networks/etc after the installation, where the dashboard configures them during the installation (with the preferences you entered)

  • I used NOOBS Lite to install Windows 10 IoT using a new 32 GB Sandisk Extreme microSD card and it worked just fine. I did not partition or format the card since it appeared to already be formatted FAT32 with a single partition. I downloaded the NOOBS zip file, extracted the contents and copied them to the microSD card. All of this with a Windows 10 PC. Then I put the card into the Pi, plugged it in, NOOBS helped me set up the WiFi, then installed Windows 10 IoT. The directions I found for NOOBS is to use the Windows 10 partition utility and standard Windows 10 copy. What is SD Formatter for? – Richard Chambers Sep 30 '17 at 23:07
  • Well, SD formatter is given as the "official" tool to format a SD card for a Pi. It has strange side effects. – Mario Stoilov Oct 2 '17 at 11:32
2

PS: After the progress finished, an error message "Failed to write provisioning file to microSD card" will be shown. The reason is that "IoT Dash Board" cannot write the provision configuration(device name, password & wlan profile) into microSD card. We are dealing with this issue. Please just ignore. Device name and password will be set to default.

Source

1

In my case, I just ignored the error message and plug in the SD card in Rasperry Pi and it works!

In the meantime, explorer pops up an error message tells me there is a drive needs to be formatted. I ignored this too. Maybe the failure message has to do with this problem.

But the password that I've set in the dashboard doesn't match, instead the default 「p@ssw0rd」for default user 「administrator」 helped me log in the IoT windows. Everything works fine.

The problem seems just vanished!

  • The failure is just writting the provision file, which contains settings (Wi-fi, username, password, etc). This error means, that it couldn't apply your settings and the defaults were left. – Mario Stoilov Feb 12 '18 at 9:34
  • I just tried to ignore this error, but when booting from the SD card, I get a "Windows Failed to Start" error message from the Windows Boot Manager. – Dave Sep 15 '18 at 1:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.