0

I have two of the originals Raspberry Pi boards (c) 2011 version. The camera connector is directly behind the ethernet connector. The SPI (black) connector is on the opposite side of the board next to the yellow audio output jack. The camera is the Pi NoIR Camera V2. I have tried two of these boards and the camera is not recognized. I have installed the latest o/s (2016-09-23-raspian-jessie.img), done the updates and rpi-update. "vcgencmd get_camera" results in supported=1, detected = 0. "raspistill -o img.jpg" result is error messages.

Does my Raspberry Pi board support this camera?

Thanks, Norm

  • Did you run raspi-config and add the camera? It adds a few necessary things to /boot/config.txt: gpu_mem=128 (the minimum for the camera to work) and start_x=1 (absurdly undesciptive and also undocumented, but presumably something to do with the camera port, since that's the only thing I've seen it related to). – goldilocks Nov 9 '16 at 20:30
  • start_x=1 causes the Pi's boot sequence to load /boot/start_x.elf (which is the firmware including the camera's GPU-based ISP) instead of the regular firmware in /boot/start.elf. The reason for the separation (I suspect) is that the camera firmware fails to load with small GPU memory splits (e.g. 16Mb); in this case the boot sequence silently falls back to the regular firmware. Why the _x suffix? Err... no idea, you'd need to ask the firmware devs :) – Dave Jones Nov 10 '16 at 14:18
  • I just checked the /boot/config file and start_x=1 and gpu_mem=128 are included in the file. – NormVA Nov 10 '16 at 14:41
  • I just checked the /boot/config file and start_x=1 and gpu_mem=128 are included in the file. I sure hope that it is a not a bad camera. I bought it on eBay, It is new, but I am sure that return would be a hassle. @goldilocks Got caught by the 5 minute edit rule. – NormVA Nov 10 '16 at 14:48
  • I have an 8 mp Noir camera and some 2011 B's, I'll check this sometime today, but I think Dave Jones is right, it should just work. Getting that cable seated properly the first time can be a bit finicky though, I'm sure the first time I plugged a camera in it did not work because of that. – goldilocks Nov 10 '16 at 14:56
1

All Pi models (with a camera connector, i.e. anything except the original Pi Zero 1.2) support both models of camera module.

The Quick Start chapter in the picamera docs goes through correct insertion and orientation of the connector cable, and enabling the camera firmware (including the fact a reboot is required after this). If you still get nothing after following those instructions, I'm afraid you may have a dead camera module (they are static sensitive and can be killed with incorrect handling).

  • I have gone through the configuration steps and verified that the commands were written to the boot/config file. I am reasonably sure that I didn't zap the board -- I handle a lot of similar static sensitive boards in building and repairing computers. Also, the ribbon cable connectors are similar to the connectors used on laptop motherboards, so I have done quite a few of these. I feel confident that it is inserted correctly. All this being said, I hate the thought of a bad camera module, bought it on eBay, so return hassle is probably not worth the cost. Thanks, Dave – NormVA Nov 10 '16 at 15:28
  • Unfortunately the V2 modules have no LED on them; on the V1 modules it was a bit easier to diagnose dead ones (LED comes on so you know power's flowing to the board but no data comes back and eventually the firmware times out with an error). It's also possible the cable is duff, but that's generally pretty visible (obvious kink or holes in the conductors). – Dave Jones Nov 10 '16 at 15:39
  • There are no visible signs of damage to the cable or camera. I have ordered a Raspberry Pi Model 3 B 1GB board. If that doesn't work, I will get a new camera. An LED would be nice. – NormVA Nov 10 '16 at 18:42
  • Yeah, when the module itself is dead there's rarely any sign of damage (at least, I've never seen any). You may want to try reseating the tiny chip on the module (labeled sunny on the v1; it's the thing just in front of the lens and can be prised up with a finger nail before reseating). If that doesn't work and your new pi doesn't either then it's definitely dead (I should add I've only once seen a dead CSI interface on the pi itself) – Dave Jones Nov 10 '16 at 19:22
  • 1
    Tried to move to chat, but link does not seem to be working. I purchased two Model B Pi 2 (5MP) cameras. They work perfectly. with no changes in HW or SW. Would there be something unique to the NoIR camera? I think they want us to move this to chat -- I am not sure how to do that. Thanks, Norm – NormVA Nov 16 '16 at 0:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.