0

I just have to say that openHAB sucks! It is so poorly documented and slow but using it as it seems the most flexible in terms of options.

I can not for the life of me get the Aeon Labs z-stick to work. I'm running a Raspibian on a Raspberry Pi and openHAB.

I have the Gen5 Z-Stick. Under windows I can communicate with the stick and see a device that has been paired with it.

I plug the stick into my raspberry pi (or unplug it) I do see the /dev/ttyACM0 device come and go accordingly.

I can not get the dam openHAB to give me any debug information about what is going on with the org.openhab.binding.zwave addon. I can find no documentation on the logback.xml file so inferring from the lines within the file I added this entry:

<logger name="org.openhab.binding.zwave" level="DEBUG" />

I run a tail -f /var/log/openhab/openhab.log and I never see anything related to zwave; nothing close to it.

My openhab.cfg was modified to have this line:

zwave:port=/dev/ttyACM0

my demo.sitemap file looks like so:

sitemap demo label="My Castle"
{
    Frame label="Lock" {
         Switch item=Door_Lock
        }

}

my demo.items file was pruned down to look like so:

Group All
Group gGF       (All)
Group gFF       (All)
Group gC        (All)
Group Outdoor   (All)
Group Shutters  (All)
Group Weather   (All)
Group Status    (All)

Group GF_Living     "Living Room"   <video>     (gGF)
Group GF_Kitchen    "Kitchen"       <kitchen>   (gGF)
Group GF_Toilet     "Toilet"        <bath>      (gGF)
Group GF_Corridor   "Corridor"      <corridor>  (gGF)

Group FF_Bath       "Bathroom"      <bath>      (gFF)
Group FF_Office     "Office"        <office>    (gFF)
Group FF_Child      "Child's Room"  <boy1>      (gFF)
Group FF_Bed        "Bedroom"       <bedroom>   (gFF)
Group FF_Corridor   "Corridor"      <corridor>  (gFF)

/* active groups */

/* Door Locks */
/*Switch Door_Lock "Front Door Lock" <none> (GF_Corridor) {zwave="2:command=switch_binary"}*/
Switch Door_Lock "Front Door Lock" <none> (GF_Corridor) {zwave="2:command=door_lock"}
Contact Door_Basic "Front door lock" <lock> (GF_Corridor) {zwave="2:command=door_lock,refresh_interval=20"}
Number Door_Corridor_Battery "Door lock battery level [%d %%]" (GF_Corridor) { zwave="2:command=battery" }

I'm about ready to give up on openHAB. Came here as last ditch approach to see if anyone could lend some suggestions or if you spot the error of my ways, please let me know.

UPDATE: The addons directory was not suppose to be in /etc/openhab/configurations/addons but rather in /usr/share/openhab/addons. I don't know why package maintainers do this idiotic practice of spreading crap our among a bunch of directories. I'm use to building stuff from source and rolling my own but in this instance I'm giving the whole apt-get install a try and I hate it lol.

So now I get this in my logs

No command class found for item = Door_Lock, command class name = switch_binary, ignoring execute refresh.
1

If you are seeing absolutely nothing in the logfile about ZWave, then it would suggest that the ZWave binding is not running. When the binding starts, it logs a message "Z-Wave binding starting" at INFO level, so it should be logged under default log conditions.

I assume from the config that you're running OH1 (?) so to get the ZWave binding running, you should add both the ZWave JAR, and the serial jar. Both JARs need to be added to the addons folder under OH1.

The other common problem with a Pi is access to the serial port - often it requires additional privileges, although if you are running as root, this shouldn't be an issue.

You possibly should also enable debug logging so that you will have more information about what is happening - this is described in the wiki (https://github.com/openhab/openhab/wiki/Z-Wave-Binding#logging). This probably won't help though until you are getting "Z-Wave binding started" type messages in the log.

If you haven't already tried posting on the openhab forum, I would recommend it as there are many helpful people there (http://community.openhab.org).

| improve this answer | |
  • thank you for your help. So I finally got the the zwave binding working. I followed some directions that said to created the addons folder and I did so via the samba share that they said to use which on the Pi is /etc/openhab/addons and that was my issue. openhab is looking for the addons in /usr/share/openhab. After copying , I immediately see communication with my nodes. – Eric Nov 12 '16 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.