1

I posted a thread on the raspberry pi forums, but I believe my problem is too obscure to be helped there. Info below:

Hello,

I absolutely an unable to get my raspberry pi to open a serial connection to a usb to serial adapter (/dev/ttyusb0) I have even have attempted to use a TTL level shifter and use the GPIO pins (/dev/ttyAMA0)

No matter what, Putty, Minicom, Picocom, are unable to open a serial port connection to the adapter, and subsequently, the terminal node controller (TNC) it is attached to.

I've tried messing with the config file for serial connections.

I have tried PL2303 Prolific chip, FTDI FT232, and an RT Systems usb to DB25 adapter.

I refuse to believe the Pi is not capable of a simple dumb terminal connection. Even IT Dept at work can't figure it out!

Help from a friend:

Not all USB<>Serial adapters are linux compatible. The best ones have the Prolific PL2303 chipset... very plug n play with a Pi or Linux bort ontinue without paging ext Message Continue...c (which is what the Pi runs). The dumb terminal program you probably want to use is called Minicom. There's no com1/com2/etc. You'll need to run at a prompt "ls /dev/ttyU*" and see what USB interface it's grabbed, and then set minicom to use that with full path.

I'm using raspberry Pi 3 B running NOOBS

Modem: http://www.kantronics.com/products/kpc3.html

Pi sees the adapter "bus 004"
i@raspberrypi:~ $ lsusb
Bus 001 Device 006: ID 04f2:0939 Chicony Electronics Co., Ltd
Bus 001 Device 005: ID 04f2:0833 Chicony Electronics Co., Ltd
Bus 001 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg kernal entries

[ 5.153584] usbcore: registered new interface driver usbserial
[ 5.153711] usbcore: registered new interface driver usbserial_generic
[ 5.153856] usbserial: USB Serial support registered for generic
[ 5.167512] usbcore: registered new interface driver ftdi_sio
[ 5.167656] usbserial: USB Serial support registered for FTDI USB Serial Device
[ 5.167963] ftdi_sio 1-1.2:1.0: FTDI USB Serial Device converter detected
[ 5.168202] usb 1-1.2: Detected FT232RL
[ 5.172224] usb 1-1.2: FTDI USB Serial Device converter now attached to ttyUSB0

google searching yields little help, I've tried a few coding tricks such as trying to assign a symbolic link to the usb0 and serial port. I've also tried modifying the boot entry to register the usb cable product and vendor ID but I get permission denied. Not sure if those solutions would help.

The system recognizes the ftdi_sio driver and device, which is puzzling. I use PuTTy using default recommended settings, which work on my laptop. I've also used minicom with the same type of failure.

The cables and modem work fine on my Win10 Laptop.

  • Someone may come along with something useful to say, but if not, you need to organize yourself more coherently. Rather than going on about your IT dept. and what your friend said, etc., focus on clearly demonstrating the problem in a reproducible way. The test connecting the USB cable via a level shifter to the GPIO UART is a perfect opportunity to do that, but there are so many ways to do it wrong that unless you explain explicitly and in detail what you did, there is not much motive for someone else to care whether you did it right and take this question seriously. – goldilocks Nov 15 '16 at 3:40
  • And if no one takes you seriously, you will suffer the same "obscure" fate that you have elsewhere. "Explicitly and in detail" means a photograph of the connections, exactly what you did for the test, and exactly what happened, not just "I tried minicom and picocom and whatevercom and nothing works", etc. – goldilocks Nov 15 '16 at 3:40
  • 1
    And we are absolutely unable to help people who don't tell us what they have tried that doesn't work. How-do-i-make-serial-work-on-the-raspberry-pi3 may help. – Milliways Nov 15 '16 at 5:37
  • In my crystall ball I can see you're trying to use the terminal as a regular user, but forgot to give yourself permissions with e.g. sudo adduser pi dialout. – Dmitry Grigoryev Nov 15 '16 at 14:55
  • I solved this myself just by coincidence tonight. Can I mark this thread as solved so others may benefit from it? – PacketRealm Nov 15 '16 at 23:03
1

SOLVED

I just found out the issue was because I was typing in /dev/ttyusb0 and not /dev/ttyUSB0. It is case sensitive!!! Thank you for trying to help. I spent weeks and hours pulling my hair out trying to figure this out.

  • Please mark this as answered. You should have enough rep now. Thanks for sharing. – Piotr Kula Nov 15 '16 at 23:20
  • 1
    When working with SSH or terminal, I usually avoid such problems by using the bash auto-completion and also gets tasks done faster if used correctly. – Shreyas Murali Nov 15 '16 at 23:30
  • I will tomorrow. It says I need to wait a day before accepting my own answer. – PacketRealm Nov 16 '16 at 0:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.