3

I have 10 Rpi2s with me and I have created a setup like this. My Windows system clock is set to local time once and I expect it to be powered at all times. It is a Workstation class system and it acts as a local server collecting data from all the 10 RPi2s.

Ten Raspberry Pi 2s connected to a local system over a router.

I want all of my Rpi2s system clocks to get synced with the Window's System Time every time they power up.

How can I achieve this? If this is possible at all?

  • 2
    You could setup your server to act as a ntp server and configure the Pi to use this. If the Pi have internet access it would probaably be simpler to let all systems sync to the external ntp servers. – Milliways Nov 15 '16 at 10:56
  • 1
    Apparently Windows uses an ntp client so there should be a server available. – goldilocks Nov 15 '16 at 13:23
4

You want to set up your Raspberry Pis to sync their time with your Windwos Server via the Network Time Protocol (NTP).

In Raspbian ntp is enabled by default, therefore you only need to add your server to the list of time servers. To do that, you need to open /etc/ntp.conf and add another line among these:

server 0.debian.pool.ntp.org iburst
server 1.debian.pool.ntp.org iburst
server 2.debian.pool.ntp.org iburst
server 3.debian.pool.ntp.org iburst

Unfortunately, how to setup your Windows NTP server lies outside the scope of this website, however this might be a good start.

Remember, UDP port 123 is used by ntp, so check your firewall settings.

| improve this answer | |
  • Must confess on my 'Doze boxes I use the Meinberg Windows port of NTP which even includes a nice system tray monitor, the file you probably want is currently the "ntp-4.2.8p8-win32-setup.exe" on meinbergglobal.com/english/sw/ntp.htm ...! – SlySven Nov 16 '16 at 19:52
  • I've followed the steps to make my Windows PC as NTP server but the clocks of my RPi are not syncing with it. My Windows PC's IP is 192.168.0.101. In the /etc/ntp.conf file I've added "server 192.168.0.101 iburst". Then I've restarted the RPis but the clocks are still out of sync. Help! – HaggarTheHorrible Nov 17 '16 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.