0

Years ago I bought a screen on Amazon

Bus 001 Device 005: ID 0eef:0001 D-WAV Scientific Co., Ltd eGalax TouchScreen

A couple days I'm trying to get it running on my PI (newest Jessie on Pi B Rev2). I stumbled over a bunch of how-tos and tried a lot of stuff (except compiling a new kernel) but I was not able to get the touch running.

I tried to replace the kernel - didn't even boot (prob. wrong version?). I flashed the delivered ISO - booted, but no touch reactions. Was not able to setup the drivers. And after reading this I decided to do nothing than just run the xinput_calibrator. No reaction either.

So after some research at SE I found how to that gave me some commands to figure out if things are properly set up (on a Jessie version from scratch)

> demsg
[    3.170995] usb 1-1.3: new low-speed USB device number 5 using dwc_otg
[    3.278800] usb 1-1.3: New USB device found, idVendor=0eef, idProduct=0001
[    3.278839] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.278859] usb 1-1.3: Product: USB TouchController
[    3.278879] usb 1-1.3: Manufacturer: eGalax Inc.
[   10.294066] input: eGalax Inc. USB TouchController as /devices/platform/soc/20980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/input/input2
[   10.311955] usbcore: registered new interface driver usbtouchscreen

> lsmod | grep touch
usbtouchscreen         14176  0

> cat /proc/bus/input/devices
I: Bus=0003 Vendor=0eef Product=0001 Version=0100
N: Name="eGalax Inc. USB TouchController"
P: Phys=usb-20980000.usb-1.3/input0
S: Sysfs=/devices/platform/soc/20980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/input/input2
U: Uniq=
H: Handlers=mouse1 event2
B: PROP=0
B: EV=b
B: KEY=400 0 0 0 0 0 0 0 0 0 0
B: ABS=3

So I had pretty much the same outputs as the blogger described.

The questions you might help me with:

  1. Am I guessing right that I don't need to compile a kernel? according to: GitHub
  2. Should my display work with the setup from above?
  3. How can I figure out, if my touch (device) works at all?
1

You already got an input device, that's good as it means the kernel has an input driver for that touch controller. Now go and install the evtest tool to find out whether your device delivers events.

See https://wiki.ubuntu.com/DebuggingTouchpadDetection/evtest

If that works, check whether your Touch is found by X11 by using

$ xinput list

Come again when you checked all these.

  • Thanks for your feedback, meanwhile I'm on other projects, but I'll try next time I'm on the pi and let you know! – Basti Jan 26 '17 at 13:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.