0

I decided to ask you for help because of despair - I don't understend how to start working with my nrf24le1 (32 pin version) on Raspberry Pi 2. What I do: I connect nrf24le1 using following pins:

FCSN (p1.1)-> SPI0 CS0
FMISO (p1.0)-> SPI0 MISO
FMOSI (p0.7)-> SPI0 MOSI
FSCK (p0.5)-> SPI0 SCLK
VDD->3.3V
GND-> GND
RESET-> GND
PROG-> any GPIO port, for example, GPIO5.

Then I use library nrf24le1-libbcm2835 downloaded from here (it is modified library, original is on Github, but I can't compile it). I run it by ./nrf24le1 test and program hangs on "[nrf24le1] nrf24le1_init: Initializing nRF24LE1" I think that my fault is in connecting PROG and RESET to wrong pins. Please, can you help me?

Scheme of nrf24le1 Pinout of nrf24le1

0

I hope you have already solved this problem: bcm2835 needs root privileges,   sudo ./nrf24le1 test will be correct. Or sudo chmod u+s nrf24le1

| improve this answer | |
  • Do you mind using only English on the RaspberryPi.SE? – techraf Dec 29 '16 at 22:40
  • Hello. Using 'sudo ./nrf24le1 test' I get the result as without sudo, and after I executed 'sudo chmod u+s nrf24le1' it returns me 'bcm2835_init: Unable to open /dev/mem: Permission denied bcm2835 init failed' – Rinat Sakaev Dec 31 '16 at 8:41
  • I recommend that you download the new version of the programming and execute it install sudo make install. I also faced this problem and found that it can be easily solved. – Artem Kolesnikov Jan 5 '17 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.