0

I was using uv4l package for streaming.suddenly it stopped working when I want run this command for example : "sudo uv4l -nopreview —auto-video_nr —driver raspicam —encoding mjpeg —width 640 —height 480 —framerate 20 —server-option '--port=9090' —server-option '--max-queued-connections=30' —server-option '--max-streams=25' —server-option '--max-threads=29'"

it return with this error : [core] No device detected

by the way uv4l is running background when it Raspberry restarts on boot and it's available on port 8080 and streams the video on http://raspberryIp:8080/stream but it seem I can not start another server Thanks in advance

  • This could work: sudo uv4l -nopreview —auto-video_nr —driver raspicam —encoding mjpeg —width 640 —height 480 —framerate 20 —server-option --port=9090 —server-option --max-queued-connections=30 —server-option --max-streams=25 —server-option --max-threads=29 – kuzeyron Sep 4 '17 at 10:29
0

I think the device resource can be allocated in a mutual exclusive manner by processes.

  • Hi, what do you mean by that? What should I do? Any clue or solution? – Ali Titan Nov 24 '16 at 9:47
  • I mean the camera can be used by a single process at a time. – vaha Nov 24 '16 at 9:48
  • No I don't think so, because as I said it was working with these conditions, and even though I kill the running uv4l process before run new server but the same result. – Ali Titan Nov 24 '16 at 11:31
  • You say that you are able to start multiple uv4l??? – vaha Nov 24 '16 at 11:33
  • maybe!! I edited my last comment read the end... "and even though I kill the running uv4l process before run new server but the same result. " – Ali Titan Nov 24 '16 at 11:35
0

Your new stream will be on '--port=9090'.

port=8080 is the default value.

so change your ip to: http://raspberrypiIp:9090/stream

or maybe your threadS flag IS causing a problem with the CPU.

Not sure if this could cause a problem, but maybe your trying to use two different encoding types which is causing a problem.

Or the --encoding=mjpeg' (I think the default is jpeg.) Do you have$ sudo apt-get install uv4l-mjpegstream` ?

Have you tried $ sudo service uv4l_raspicam restart ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.