7

Raspberry Pi 3 Model B running Raspbian "Jessie with PIXEL" (Release 2016-09-23).

It appears that all the WiFi networks that requires authentication other than a PSK are grayed out in the menu.

What is the reason behind this? Not supported by driver or not support by GUI?

Thanks!

Screen

3 Answers 3

12

Turns out it is just the GUI that does not support WPA2 Enterprise. Was able to connect to those grayed-out networks by manually modifying /etc/wpa_supplicant/wpa_supplicant.conf as follows:

network={
    ssid="VostroNet"
    key_mgmt=WPA-EAP
    eap=TTLS   //put your EAP method
    identity="xxxxx"
    password="xxxxx"
    phase2="auth=MSCHAPv2"
}
1
  • 1
    Hello and welcome to Raspberry Pi! Thank you for comming back and providing an answer on your own. Please take the tour and visit the helpcenter.
    – Ghanima
    Nov 23, 2016 at 22:46
3

Most of the answers I found online were obsolete, with the latest release of Raspbian. I made a post with the fix, Connecting a Raspberry Pi 3 to Enterprise Wifi:

Type this in your terminal :

sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Edit the contents of the file to the following :

network={
      ssid=""
      priority=1
      proto=RSN
      key_mgmt=WPA-EAP
      pairwise=CCMP
      auth_alg=OPEN
      eap=PEAP
      identity=""
      password=""
      phase1="peaplabel=0"
      phase2="auth=MSCHAPV2"
      }

Press Ctrl+O to save and Ctrl+X to exit.

Fill in the blanks:

  • ssid with your University wifi’s ssid(name);
  • identity with your username, and;
  • password with your password.
1
  • Its not working for me. I am trying to connect Raspberry pi in industry solution and using latest Raspbian Buster OS. tried with wpa_supplicant option but does not work for cisco router with much of the parameter are not known to me. Only sure that they are using WPA-EAP and username passowrd.
    – Rajendra
    Oct 16, 2019 at 5:09
0

For the eduroam environment in our university, the wpa_supplicant.conf looks like this:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=NL

network={
  ssid="eduroam"
  scan_ssid=1
  key_mgmt=WPA-EAP
  eap=PEAP
  identity="[email protected]"
  password="MyPassword"
  phase1="peaplabel=0"
  phase2="auth=MSCHAPV2"
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.