0

I'm using a Rpi B rev2 and I'm having problems changing the output of ports 2,3,4,5,6 (BCM). All the other ports work perfectly. I searched for documentation and I see the only thing that sets these apart is that they have a default HIGH pull resistor activated. (source: https://www.raspberrypi.org/wp-content/uploads/2012/02/BCM2835-ARM-Peripherals.pdf)

Whatever I do (cleanup, define a DOWN pull resistor), I can't get it to change. Can somebody clarify this behavior?

PS: I use python rpi.gpio on a Archlinux Arm distro

EDIT: As per request; the code

import RPi.GPIO as GPIO
GPIO.setmode(GPIO.BCM)
GPIO.setup(4,GPIO.OUT) #per example pin 4
GPIO.output(4,1)

The voltage on the pin 4 is a 0.8V, when I change it to 0, still the same. On all other +- 20 ports this works.

UPDATE: Due to tests I ran with hooking up a mosfet, I broke a couple of GPIO pins, Joan (see above) his tool is a great way of testing your GPIO pins. Credits to him

  • Please post the code you use in trying to switch the GPIOs' state. – Fantilein1990 Nov 23 '16 at 13:43
2

GPIO 5 and GPIO 6 are not brought out to the expansion header on a PiB Rev.2. How are you testing their value?

GPIO 2, 3, and 4 are connected to expansion header pins 3, 5, and 7 respectively.

How are you testing their value?

GPIO 2 and 3 have hard wired 1k8 pull-ups to 3V3. GPIO 4 has a weak internal pull-up to 3V3 enabled at power-up.

You can use http://abyz.me.uk/rpi/pigpio/faq.html#Have_I_fried_my_GPIO to check your GPIO.

  • I'm checking some things now with wiringPI but same result. I'm testing the value with a multimeter (set to volts, black to GND pin RPIm other to pin) – Polarsbear Nov 23 '16 at 15:37
  • It's a B+ I'm sorry, My situation is that 16 pins are perfectly working, but 4,5,6 (GPIO.BCM) are not working. I test if I fried my pi – Polarsbear Nov 23 '16 at 15:38
  • Your program gives me an error (libpigpiod.so: no such file) – Polarsbear Nov 23 '16 at 16:01
  • It uses pigpio which isn't installed on Arch by default. Try wiringPi's pintest program. It should be under the wiringPi installation directory. – joan Nov 23 '16 at 16:05
  • I installed pigpio, put still, I'll try wiringPI – Polarsbear Nov 23 '16 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.