0

I want to setup a Raspberry Pi zero as a headless data collection and communicator. The way I want to do it is as follows:

Connect the sensors using USB or I2C or SPI. Once the data is communicated to the Pi, it transmits the data over Xbee to a PC.

To add more functionality I want to have a SSH running over the Xbee connections, so that I can start and stop, and possible change some python code over the xbee , using the PC(something that will be convenient during system upgrades).

Currently I have used established a shell through the serial port using a USB to TTL cable, and its worked. I have a pair of Xbee series 2 and I have set them up for communication (one is the Xbee coordinator AT, the other is just a Xbee AT).

I am assuming that the XBee in AT mode will behave just like a wired connection.

When I replace the USB/TTL wire with the modules I do not get access to the shell, its just a blank screen. To test further, Ive done a hot swap i.e starting the system first with USB/TTL wire, logging in and switching to Xbee, but no luck, the Xbee com screen is just blank.

Any idea where the error may be? or what different implementations of the systems can I use to accomplish my objectives?

  • did you need two Xbees plugged in to the Pi or were you able to ssh in to the same Xbee that is transmitting your data? – hansmosh Mar 20 '17 at 23:37
  • I just use one xbee connected to the Rpi, but most of the time its operating simplex, never tested as duplex. – user3806817 Mar 29 '17 at 21:32
  • Interesting. So whenever you login over the xbee tx/rx, you first stop any application that is sending data out over the xbee? My situation is such that the only way I would be able to stop an application like that is by first logging in over the xbee serial port. Did you need to do any additional setup on the pi to enable logging in over serial (for example, if you're hooking the xbee up over usb) or were you just using the pi's tx/rx pins that already allow serial login? Thanks. – hansmosh Mar 29 '17 at 21:53
1

Got it to work, I was making the mistake of hooking the RPi TX to the XBee TX, when instead it should be:

RPI ||| XBEE

TX <--> RX

RX <--> TX

  • You always need to swap the connection that way :) – Luis Diaz Sep 11 '17 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.