2

How can we change the network interface Kodi is listening to?

pi@raspberrypi:~ $ sudo netstat -tnlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address     Foreign Address   State    PID/Program name
tcp        0      0 0.0.0.0:1183      0.0.0.0:*         LISTEN   3730/kodi.bin   
tcp        0      0 127.0.0.1:9090    0.0.0.0:*         LISTEN   3730/kodi.bin  

I am trying to use Kore to be able to control Kodi through my mobile phone. However, Kore can't find any media center on the network. I suspect the fact that Kodi is listening on the Local loopback interface instead of eth0.

Is there a way to change it?

1
  • Kodi settings, you need to enable remote control access. When I get back I'll post an answer – ElefantPhace Nov 26 '16 at 8:50
2

From Kodi

goto System > Settings

enter image description here

goto Services

enter image description here

goto Web Server

enter image description here And enable, set whatever credentials you want.

goto Remote Control

enter image description here

Enable both

Allow remote control by programs on this system

and also

Allow remote control by programs on other systems

You should now be able to use Kore to search for Media Centers on your network, connect, and control your Kodi box

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.